summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/noiz2sa/noiz2sa-0.51a-r2.ebuild')
-rw-r--r--games-action/noiz2sa/noiz2sa-0.51a-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-action/noiz2sa/noiz2sa-0.51a-r2.ebuild b/games-action/noiz2sa/noiz2sa-0.51a-r2.ebuild
new file mode 100644
index 000000000000..068023a39b23
--- /dev/null
+++ b/games-action/noiz2sa/noiz2sa-0.51a-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Abstract Shooting Game"
+HOMEPAGE="https://www.asahi-net.or.jp/~cs8k-cyu/windows/noiz2sa_e.html https://sourceforge.net/projects/noiz2sa/"
+SRC_URI="mirror://sourceforge/noiz2sa/${P}.tar.gz"
+S="${WORKDIR}/${PN}/src"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/libbulletml-0.0.3
+ media-libs/libsdl[joystick]
+ media-libs/sdl-mixer[vorbis]
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc41.patch
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+src_prepare() {
+ default
+
+ cp makefile.lin Makefile || die
+
+ tc-export CC CXX
+}
+
+src_install() {
+ local datadir="/usr/share/games/${PN}"
+
+ dobin ${PN}
+ dodir "${datadir}"
+ dodoc ../readme*
+
+ cp -r ../noiz2sa_share/* "${D}/${datadir}" || die
+}