summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/supertuxkart/supertuxkart-1.3.ebuild')
-rw-r--r--games-action/supertuxkart/supertuxkart-1.3.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/games-action/supertuxkart/supertuxkart-1.3.ebuild b/games-action/supertuxkart/supertuxkart-1.3.ebuild
index 38c265b6f264..d3a6aa690718 100644
--- a/games-action/supertuxkart/supertuxkart-1.3.ebuild
+++ b/games-action/supertuxkart/supertuxkart-1.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake desktop xdg
+inherit cmake desktop flag-o-matic xdg
MY_P="SuperTuxKart-${PV}-src"
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/${PN}/stk-code/releases/download/${PV}/${MY_P}.tar.x
LICENSE="GPL-2 GPL-3 CC-BY-SA-3.0 CC-BY-SA-4.0 CC0-1.0 public-domain ZLIB"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="debug nettle recorder sqlite wiimote"
# don't unbundle irrlicht and bullet
@@ -63,15 +63,24 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858521
+ # https://github.com/supertuxkart/stk-code/issues/5035
+ #
+ # The issue is bundled code from sci-physics/bullet which is unlikely to
+ # be debundled.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DUSE_SQLITE3=$(usex sqlite)
-DUSE_SYSTEM_ANGELSCRIPT=ON
-DUSE_SYSTEM_ENET=ON
- -DUSE_SYSTEM_GLEW=ON
-DUSE_SYSTEM_SQUISH=OFF
-DUSE_SYSTEM_WIIUSE=OFF
-DUSE_IPV6=OFF # not supported by system enet
- -DOpenGL_GL_PREFERENCE=GLVND
-DUSE_CRYPTO_OPENSSL=$(usex nettle no yes)
-DBUILD_RECORDER=$(usex recorder)
-DUSE_WIIUSE=$(usex wiimote)