summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/teeworlds/teeworlds-0.7.5-r1.ebuild')
-rw-r--r--games-action/teeworlds/teeworlds-0.7.5-r1.ebuild47
1 files changed, 13 insertions, 34 deletions
diff --git a/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild b/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild
index 84c2689ed33f..6eb673a54626 100644
--- a/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild
+++ b/games-action/teeworlds/teeworlds-0.7.5-r1.ebuild
@@ -5,18 +5,12 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-COMMIT_LANG="4ba6f824e9c34565e61340d25bc8c3cc004d40fb"
-COMMIT_MAPS="1d3401a37a3334e311faf18a22aeff0e0ac9ee65"
-inherit cmake desktop python-any-r1 xdg-utils
+inherit xdg cmake desktop python-any-r1
DESCRIPTION="Online multi-player platform 2D shooter"
HOMEPAGE="https://www.teeworlds.com/"
-SRC_URI="
- https://github.com/ktrace/gentoo-blobs/raw/master/teeworlds.png
- https://github.com/teeworlds/teeworlds/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/teeworlds/teeworlds-maps/archive/${COMMIT_MAPS}.tar.gz -> ${P}-maps.tar.gz
- https://github.com/teeworlds/teeworlds-translation/archive/${COMMIT_LANG}.tar.gz -> ${P}-translation.tar.gz
-"
+SRC_URI="https://github.com/teeworlds/teeworlds/releases/download/${PV}/teeworlds-${PV}-src.tar.gz"
+S="${WORKDIR}/${P}-src"
LICENSE="ZLIB"
SLOT="0"
@@ -36,18 +30,10 @@ RDEPEND="
)
dev-libs/openssl:0=
sys-libs/zlib"
-
-DEPEND="${RDEPEND} ${PYTHON_DEPS}"
-
-src_prepare() {
- cmake_src_prepare
- rm -r "${S}/datasrc/languages" || die
- rm -r "${S}/datasrc/maps" || die
- mv "${WORKDIR}/${PN}-translation-${COMMIT_LANG}" "${S}/datasrc/languages" || die
- mv "${WORKDIR}/${PN}-maps-${COMMIT_MAPS}" "${S}/datasrc/maps" || die
- cp "${DISTDIR}/${PN}.png" "${S}/" || die
- python_fix_shebang scripts/
-}
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/imagemagick-tools[png]"
src_configure() {
local mycmakeargs=(
@@ -55,25 +41,18 @@ src_configure() {
-DDEV=$(usex debug ON OFF)
-DPYTHON_EXECUTABLE="${PYTHON}"
)
-
cmake_src_configure
}
src_install() {
cmake_src_install
- doicon -s 256 "${PN}.png"
+
+ convert "other/icons/teeworlds.ico[0]" ${PN}.png || die
+ doicon -s 256 ${PN}.png
+
domenu other/teeworlds.desktop
newinitd "${FILESDIR}"/${PN}-init.d ${PN}
- insinto "/etc/${PN}"
- doins "${FILESDIR}"/teeworlds_srv.cfg
-}
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/teeworlds_srv.cfg
}