summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/wordwarvi/wordwarvi-1.00.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/games-action/wordwarvi/wordwarvi-1.00.ebuild b/games-action/wordwarvi/wordwarvi-1.00.ebuild
index 0ef897387f76..38eae15bce1e 100644
--- a/games-action/wordwarvi/wordwarvi-1.00.ebuild
+++ b/games-action/wordwarvi/wordwarvi-1.00.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
@@ -24,12 +24,10 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-sound.patch
sed -i \
-e "/^WITHAUDIO/s/yes/$(use portaudio && echo yes || echo no)/" \
- Makefile \
- || die "sed failed"
+ Makefile || die
sed -i \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
- wwviaudio.c \
- || die "sed failed"
+ wwviaudio.c || die
}
src_compile() {