summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/heroes/files/heroes-0.21-automake-1.12.patch11
-rw-r--r--games-action/heroes/files/heroes-0.21-autotools.patch30
-rw-r--r--games-action/heroes/files/heroes-0.21-underlink.patch11
-rw-r--r--games-action/heroes/heroes-0.21-r2.ebuild43
4 files changed, 48 insertions, 47 deletions
diff --git a/games-action/heroes/files/heroes-0.21-automake-1.12.patch b/games-action/heroes/files/heroes-0.21-automake-1.12.patch
deleted file mode 100644
index 1a645df91acb..000000000000
--- a/games-action/heroes/files/heroes-0.21-automake-1.12.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- heroes-0.21/configure.ac
-+++ heroes-0.21/configure.ac
-@@ -112,7 +112,7 @@
- # Checks for typedefs, structures, and compiler characteristics.
- # ==============================================================
-
--AM_C_PROTOTYPES
-+AC_C_PROTOTYPES
- AC_C_CONST
- AC_TYPE_UID_T dnl This checks for gid_t too.
- AC_CHECK_TYPES([ssize_t])
diff --git a/games-action/heroes/files/heroes-0.21-autotools.patch b/games-action/heroes/files/heroes-0.21-autotools.patch
new file mode 100644
index 000000000000..c6dfb9fab1a7
--- /dev/null
+++ b/games-action/heroes/files/heroes-0.21-autotools.patch
@@ -0,0 +1,30 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -44,6 +44,7 @@
+ AM_PROG_CC_C_O
+ AC_PROG_CPP
+ AC_PROG_AWK
++AM_PROG_AR
+ AC_PROG_RANLIB
+ AC_PROG_LN_S
+
+@@ -112,7 +113,7 @@
+ # Checks for typedefs, structures, and compiler characteristics.
+ # ==============================================================
+
+-AM_C_PROTOTYPES
++AC_C_PROTOTYPES
+ AC_C_CONST
+ AC_TYPE_UID_T dnl This checks for gid_t too.
+ AC_CHECK_TYPES([ssize_t])
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -42,7 +42,7 @@
+ heroeslvl_SOURCES = heroeslvl.c
+
+ heroes_LDADD = lvl/libhlvl.a media/libhmcommon.a ../lib/libheroes.a \
+- $(INTLLIBS) $(LIBALT_LOCAL_XLDADD) $(LIBALT_XLDADD)
++ $(INTLLIBS) $(LIBALT_LOCAL_XLDADD) $(LIBALT_XLDADD) -lm
+ heroes_LDFLAGS = $(LIBALT_XLDFLAGS)
+
+ ## Depend upon Makefile because the value of LIBALT_LOCAL_LDADD might
diff --git a/games-action/heroes/files/heroes-0.21-underlink.patch b/games-action/heroes/files/heroes-0.21-underlink.patch
deleted file mode 100644
index 18a0fca28f3c..000000000000
--- a/games-action/heroes/files/heroes-0.21-underlink.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/Makefile.am 2011-06-10 11:32:03.905618275 +0200
-+++ b/src/Makefile.am 2011-06-10 11:32:15.539347083 +0200
-@@ -42,7 +42,7 @@
- heroeslvl_SOURCES = heroeslvl.c
-
- heroes_LDADD = lvl/libhlvl.a media/libhmcommon.a ../lib/libheroes.a \
-- $(INTLLIBS) $(LIBALT_LOCAL_XLDADD) $(LIBALT_XLDADD)
-+ $(INTLLIBS) $(LIBALT_LOCAL_XLDADD) $(LIBALT_XLDADD) -lm
- heroes_LDFLAGS = $(LIBALT_XLDFLAGS)
-
- ## Depend upon Makefile because the value of LIBALT_LOCAL_LDADD might
diff --git a/games-action/heroes/heroes-0.21-r2.ebuild b/games-action/heroes/heroes-0.21-r2.ebuild
index 9e7f8d9fcc0d..a576ebf8f758 100644
--- a/games-action/heroes/heroes-0.21-r2.ebuild
+++ b/games-action/heroes/heroes-0.21-r2.ebuild
@@ -20,10 +20,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ggi nls sdl"
+REQUIRED_USE="^^ ( ggi sdl )"
RESTRICT="test"
-REQUIRED_USE="^^ ( ggi sdl )"
-RDEPEND="ggi? (
+RDEPEND="
+ ggi? (
media-libs/libggi
media-libs/libgii
media-libs/libmikmod
@@ -33,49 +34,41 @@ RDEPEND="ggi? (
media-libs/libsdl
media-libs/sdl-mixer
)"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
- #56118
PATCHES=(
- "${FILESDIR}/${P}"-automake-1.12.patch
- "${FILESDIR}/${P}"-gcc4.patch
- "${FILESDIR}/${P}"-underlink.patch
- "${FILESDIR}/${P}"-cvs-segfault-fix.patch
- "${FILESDIR}/${P}"-compilation.patch
- "${FILESDIR}/${P}"-gcc10.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-gcc4.patch
+ "${FILESDIR}"/${P}-cvs-segfault-fix.patch
+ "${FILESDIR}"/${P}-compilation.patch
+ "${FILESDIR}"/${P}-gcc10.patch
)
src_prepare() {
default
- sed -i 's:$(localedir):/usr/share/locale:' \
- $(find . -name 'Makefile.in*') || die
eautoreconf
}
src_configure() {
- local myconf=(
- $(use_with sdl)
- $(use_with sdl sdl-mixer)
- $(use_with ggi)
- $(use_with ggi mikmod)
- $(use_enable nls)
- )
-
local pkg
- for pkg in ${A//.tar.bz2} ; do
- cd "${WORKDIR}"/${pkg}
+ for pkg in ${A//.tar.bz2}; do
+ cd "${WORKDIR}"/${pkg} || die
econf \
--disable-heroes-debug \
--disable-optimizations \
- "${myconf[@]}"
+ $(use_with sdl) \
+ $(use_with sdl sdl-mixer) \
+ $(use_with ggi) \
+ $(use_with ggi mikmod) \
+ $(use_enable nls)
done
}
src_install() {
local pkg
for pkg in ${A//.tar.bz2} ; do
- cd "${WORKDIR}"/${pkg}
+ cd "${WORKDIR}"/${pkg} || die
emake DESTDIR="${D}" install
done
}