summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/jvgs/jvgs-0.5-r1.ebuild')
-rw-r--r--games-arcade/jvgs/jvgs-0.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/jvgs/jvgs-0.5-r1.ebuild b/games-arcade/jvgs/jvgs-0.5-r1.ebuild
new file mode 100644
index 000000000000..779b57dd7400
--- /dev/null
+++ b/games-arcade/jvgs/jvgs-0.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils
+
+DESCRIPTION="An open-source platform game with a sketched and minimalistic look"
+HOMEPAGE="http://jvgs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jvgs/${P}-src.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/lua:0
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/freetype:2
+ sys-libs/zlib:=
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+
+S=${WORKDIR}/${P}-src
+PATCHES=( "${FILESDIR}"/${PN}-0.5-fix-build-system.patch )
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r main.lua resources
+
+ newicon resources/drawing.svg ${PN}.svg
+ make_desktop_entry ${PN} ${PN}
+
+ einstalldocs
+}