summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild')
-rw-r--r--games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild b/games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild
new file mode 100644
index 000000000000..58a4339406b8
--- /dev/null
+++ b/games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit unpacker games
+
+DESCRIPTION="race marbles through crazy stages"
+HOMEPAGE="http://www.garagegames.com/pg/product/view.php?id=3"
+SRC_URI="ftp://ggdev-1.homelan.com/marbleblast/MarbleBlastDemo-${PV}.sh.bin"
+
+LICENSE="MARBLEBLAST"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/marbleblastdemo.bin
+ ${dir:1}/lib/lib*"
+
+src_install() {
+ dodir "${dir}" "${GAMES_BINDIR}"
+
+ tar -zxf MarbleBlast.tar.gz -C "${D}/${dir}" || die "extracting MarbleBlast.tar.gz"
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/marbleblastdemo
+ dosym "${dir}"/marbleblastdemo "${GAMES_BINDIR}"/marbleblast-demo
+
+ dodoc README_DEMO.txt
+
+ prepgamesdirs
+}