summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/methane/methane-2.0.1.ebuild')
-rw-r--r--games-arcade/methane/methane-2.0.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-arcade/methane/methane-2.0.1.ebuild b/games-arcade/methane/methane-2.0.1.ebuild
new file mode 100644
index 000000000000..24b1b2b6360d
--- /dev/null
+++ b/games-arcade/methane/methane-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Port from an old Amiga game"
+HOMEPAGE="https://methane.sourceforge.net/"
+SRC_URI="https://github.com/rombust/Methane/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/Methane-${PV}"
+
+RDEPEND="
+ dev-games/clanlib:4.1[opengl]
+ media-libs/libmikmod
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ tc-export PKG_CONFIG
+}
+
+src_install() {
+ dobin methane
+
+ insinto /usr/share/${PN}
+ doins resources/*
+
+ newicon docs/puff.gif ${PN}.gif
+ make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
+ HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt
+}