summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild')
-rw-r--r--games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild b/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild
new file mode 100644
index 000000000000..6fdab3042115
--- /dev/null
+++ b/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="An Alien Invaders style game with 3d graphics"
+HOMEPAGE="http://triplexinvaders.infogami.com"
+SRC_URI="http://acm.jhu.edu/~arthur/invaders/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-python/pygame
+ dev-python/pyopengl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ sound.py \
+ util.py \
+ hiscore.py \
+ options.py || die "sed failed"
+}
+
+src_install() {
+ local libdir=$(games_get_libdir)
+
+ insinto "${libdir}/${PN}"
+ doins -r *.py
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r models sound options.conf hiscores
+ games_make_wrapper ${PN} "python ./invaders.py" "${libdir}/${PN}"
+ dodoc README.txt TODO.txt
+ prepgamesdirs
+}