summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3-r1.ebuild55
-rw-r--r--games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch4
-rw-r--r--games-arcade/conveysdl/files/conveysdl-1.3-speed.patch4
3 files changed, 59 insertions, 4 deletions
diff --git a/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild b/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
new file mode 100644
index 000000000000..5c39dd327ee7
--- /dev/null
+++ b/games-arcade/conveysdl/conveysdl-1.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
+HOMEPAGE="http://www.cloudsprinter.com/software/conveysdl/"
+SRC_URI="http://www.cloudsprinter.com/software/conveysdl/${P/-/.}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # Incomplete readme
+ sed -i \
+ -e 's:I k:use -nosound to disable sound\n\nI k:' \
+ readme || die
+
+ sed -i \
+ -e 's:SDL_Mi:SDL_mi:' \
+ main.c || die
+
+ eapply \
+ "${FILESDIR}"/${P}-arrays.patch \
+ "${FILESDIR}"/${P}-speed.patch
+}
+
+src_compile() {
+ emake main \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} $(sdl-config --cflags) \
+ -DDATA_PREFIX=\\\"/usr/share/${PN}/\\\" \
+ -DENABLE_SOUND" \
+ LDLIBS="-lSDL_mixer $(sdl-config --libs)"
+}
+
+src_install() {
+ newbin main ${PN}
+ insinto /usr/share/${PN}
+ doins -r gfx sounds levels
+ newicon gfx/jblob.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Convey /usr/share/pixmaps/${PN}.bmp
+ einstalldocs
+}
diff --git a/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch b/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch
index a3894e58d3d3..a6286d96f145 100644
--- a/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch
+++ b/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch
@@ -1,5 +1,5 @@
---- main.c.org 2010-07-28 13:16:20.552161148 +0300
-+++ main.c 2010-07-29 20:43:14.714543259 +0300
+--- a/main.c.org 2010-07-28 13:16:20.552161148 +0300
++++ b/main.c 2010-07-29 20:43:14.714543259 +0300
@@ -22,7 +22,7 @@
SDL_Surface *bletters;
diff --git a/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch b/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch
index 2b5a6205650c..6d6d13eb11be 100644
--- a/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch
+++ b/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch
@@ -1,5 +1,5 @@
---- org/main.c 2010-07-30 10:41:21.392783010 +0300
-+++ main.c 2010-07-30 10:44:35.791690958 +0300
+--- a/main.c 2010-07-30 10:41:21.392783010 +0300
++++ b/main.c 2010-07-30 10:44:35.791690958 +0300
@@ -52,6 +52,7 @@