summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/berusky/berusky-1.7.1.ebuild61
-rw-r--r--games-arcade/berusky/files/berusky-1.7.1-gentoo.patch71
2 files changed, 0 insertions, 132 deletions
diff --git a/games-arcade/berusky/berusky-1.7.1.ebuild b/games-arcade/berusky/berusky-1.7.1.ebuild
deleted file mode 100644
index 93f816e6bc87..000000000000
--- a/games-arcade/berusky/berusky-1.7.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils gnome2-utils games
-
-DATAFILE=${PN}-data-1.7
-DESCRIPTION="free logic game based on an ancient puzzle named Sokoban"
-HOMEPAGE="http://anakreon.cz/?q=node/1"
-SRC_URI="http://www.anakreon.cz/download/${P}.tar.gz
- http://www.anakreon.cz/download/${DATAFILE}.tar.gz
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[X,video]
- media-libs/sdl-image[png]
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- mv ../${DATAFILE}/{berusky.ini,GameData,Graphics,Levels} . || die
- epatch "${FILESDIR}"/${P}-gentoo.patch
- sed -i \
- -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
- -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
- src/defines.h berusky.ini \
- || die
- sed -i \
- -e "/AC_INIT/s/configure.in/${PN}, ${PV}/" \
- configure.in || die
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_install() {
- default
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r berusky.ini GameData Graphics Levels
- doicon -s 32 "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN}
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-arcade/berusky/files/berusky-1.7.1-gentoo.patch b/games-arcade/berusky/files/berusky-1.7.1-gentoo.patch
deleted file mode 100644
index f26c233c39e0..000000000000
--- a/games-arcade/berusky/files/berusky-1.7.1-gentoo.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- Makefile.am
-+++ Makefile.am
-@@ -5,8 +5,7 @@
-
- SUBDIRS = po src data
-
--beruskydocdir = ${prefix}/doc/berusky
--beruskydoc_DATA = \
-+EXTRA_DIST = \
- README\
- COPYING\
- AUTHORS\
-@@ -15,10 +14,6 @@
- NEWS\
- TODO
-
--EXTRA_DIST = $(beruskydoc_DATA)
--
--
--
- # Copy all the spec files. Of cource, only one is actually used.
- dist-hook:
- for specfile in *.spec; do \
---- data/Makefile.am
-+++ data/Makefile.am
-@@ -3,10 +3,3 @@
- ## Created by Anjuta - will be overwritten
- ## If you don't want it to overwrite it,
- ## Please disable it in the Anjuta project configuration
--
--berusky_datadir = $(prefix)/@NO_PREFIX_PACKAGE_DATA_DIR@/@PACKAGE@
--
--berusky_data_DATA = \
-- berusky.ini
--
--EXTRA_DIST = $(berusky_data_DATA)
---- berusky.ini
-+++ berusky.ini
-@@ -1,9 +1,9 @@
- # Configuration for berusky game
-
- # Game data location
--level_data = /usr/share/berusky/Levels
--game_data = /usr/share/berusky/GameData
--graphics_data = /usr/share/berusky/Graphics
-+level_data = @GENTOO_DATADIR@/Levels
-+game_data = @GENTOO_DATADIR@/GameData
-+graphics_data = @GENTOO_DATADIR@/Graphics
-
- # Graphics settings for game and editor
- # game runs in 640x480
-@@ -17,7 +17,7 @@
-
- # Game binary & tmp dir
- # they're used by editor for "run level" command
--game_binary = /usr/bin/berusky
-+game_binary = @GENTOO_BINDIR@/berusky
- tmp_data = /var/tmp
-
- # Dir for users levels (it's the default level dir for level editor)
---- src/defines.h
-+++ src/defines.h
-@@ -446,7 +446,7 @@
- #define INI_USER_DIRECTORY "~/.berusky"
- #define INI_USER_LEVELS "~/.berusky/User"
- #define INI_USER_PROFILES "~/.berusky/Profiles"
--#define INI_FILE_GLOBAL "/var/games/berusky/"INI_FILE_NAME
-+#define INI_FILE_GLOBAL "@GENTOO_DATADIR@/"INI_FILE_NAME
- #define INI_FILE_USER "~/.berusky/"INI_FILE_NAME
- #define INI_FILE_LOCAL "./"INI_FILE_NAME
- #elif WINDOWS