summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/fruit/fruit-2.1.ebuild')
-rw-r--r--games-board/fruit/fruit-2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-board/fruit/fruit-2.1.ebuild b/games-board/fruit/fruit-2.1.ebuild
new file mode 100644
index 000000000000..2ba5995b3dea
--- /dev/null
+++ b/games-board/fruit/fruit-2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator games
+
+MY_PV=$(replace_all_version_separators '')
+MY_P=${PN}_${MY_PV}_linux
+DESCRIPTION="UCI-only chess engine"
+HOMEPAGE="http://arctrix.com/nas/fruit/"
+SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ option.cpp || die
+ sed -i \
+ -e '/^CXX/d' \
+ -e '/^LDFLAGS/d' \
+ Makefile || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ../book_small.bin
+ dodoc ../readme.txt ../technical_10.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To use this engine you need to install a UCI chess GUI"
+ elog "e.g. games-board/glchess"
+}