summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pioneers/Manifest1
-rw-r--r--games-board/pioneers/files/pioneers-15.5-fno-common.patch12
-rw-r--r--games-board/pioneers/pioneers-15.5.ebuild46
3 files changed, 59 insertions, 0 deletions
diff --git a/games-board/pioneers/Manifest b/games-board/pioneers/Manifest
index a1195e54057d..5f1e718393f0 100644
--- a/games-board/pioneers/Manifest
+++ b/games-board/pioneers/Manifest
@@ -1 +1,2 @@
DIST pioneers-15.3.tar.gz 4154470 BLAKE2B 536b2100ac0dd75d8c118741bffdd433bebcbdef2df54a75a5e9004f5fb2f7859bc75c27935251fc94b3428e730a7be522b88a7ab13224cb545180eb84ad86f9 SHA512 57aa8bc48019c87a683a4728d28d56f6bd755a0566922dddb4de825904820d1204f893e73fd13465fcec63cecb4a5735a90338f6ff915b7f17113dc0f1e834c1
+DIST pioneers-15.5.tar.gz 4975627 BLAKE2B 8cae5df3e122743819196f0442ba18cedcfd4fee51d9e76ef4137f120e3429456f58ca9d6e537b8e0206c937d882b4a22d76ae333a7d5d7dc69d65f7bbd94b18 SHA512 a3261197348d7e994da81ad4948755520bf29678614a9ea2b2cacc81622093c6460b0cee671a04c125684d88a9ee1deb9206ccb73ab1440be1a1505e24b2ed2a
diff --git a/games-board/pioneers/files/pioneers-15.5-fno-common.patch b/games-board/pioneers/files/pioneers-15.5-fno-common.patch
new file mode 100644
index 000000000000..5d8522b772ec
--- /dev/null
+++ b/games-board/pioneers/files/pioneers-15.5-fno-common.patch
@@ -0,0 +1,12 @@
+diff -up a/common/game.h.me b/common/game.h
+--- a/common/game.h.me 2020-02-06 12:05:24.472403768 +0100
++++ b/common/game.h 2020-02-06 12:05:45.662644226 +0100
+@@ -137,7 +137,7 @@ typedef enum {
+ typedef void (*WriteLineFunc) (gpointer user_data, const gchar *);
+
+ /** Default style for a player. */
+-const gchar *default_player_style;
++extern const gchar *default_player_style;
+
+ GameParams *params_new(void);
+ GameParams *params_copy(const GameParams * params);
diff --git a/games-board/pioneers/pioneers-15.5.ebuild b/games-board/pioneers/pioneers-15.5.ebuild
new file mode 100644
index 000000000000..afd322eae4c7
--- /dev/null
+++ b/games-board/pioneers/pioneers-15.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
+
+LICENSE="GPL-2 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated help nls"
+
+# dev-util/gob only for autoreconf
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ !dedicated? (
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libnotify-0.7.4
+ help? ( app-text/yelp-tools )
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gob:2
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog README TODO NEWS )
+
+PATCHES=( "${FILESDIR}/${P}-fno-common.patch" )
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable help) \
+ --includedir=/usr/include \
+ $(use_with !dedicated gtk)
+}
+
+src_install() {
+ gnome2_src_install scrollkeeper_localstate_dir="${ED%/}"/var/lib/scrollkeeper/
+}