summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/biloba/biloba-0.9.3-r2.ebuild48
-rw-r--r--games-board/biloba/files/biloba-0.9.3-gcc-10.patch30
2 files changed, 78 insertions, 0 deletions
diff --git a/games-board/biloba/biloba-0.9.3-r2.ebuild b/games-board/biloba/biloba-0.9.3-r2.ebuild
new file mode 100644
index 000000000000..a79b45bdd803
--- /dev/null
+++ b/games-board/biloba/biloba-0.9.3-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg-utils
+
+DESCRIPTION="a board game, up to 4 players, with AI and network"
+HOMEPAGE="http://biloba.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libsdl:0[X,video,sound]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # X11 headers are checked but not used, everything is done through SDL
+ "${FILESDIR}"/${P}-not-windows.patch
+ "${FILESDIR}"/${P}-no-X11-dep.patch
+ "${FILESDIR}/${P}-gcc-10.patch"
+)
+
+src_prepare() {
+ default
+
+ # "missing" file is old, and warns about --run not being supported
+ rm missing || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon -s 64 biloba_icon.png ${PN}.png
+ make_desktop_entry biloba Biloba
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/games-board/biloba/files/biloba-0.9.3-gcc-10.patch b/games-board/biloba/files/biloba-0.9.3-gcc-10.patch
new file mode 100644
index 000000000000..69d27f9aa7b6
--- /dev/null
+++ b/games-board/biloba/files/biloba-0.9.3-gcc-10.patch
@@ -0,0 +1,30 @@
+Description: Fix FTBFS with gcc 10
+Author: Ricardo Mones <mones@debian.org>
+Bug-Debian: https://bugs.debian.org/957039
+Last-Update: 2020-08-29
+
+diff --git a/src/utils.c b/src/utils.c
+index 73bbd05..c51365d 100644
+--- a/src/utils.c
++++ b/src/utils.c
+@@ -53,6 +53,7 @@
+
+ char *progpath = NULL;
+ char *langpath = NULL;
++SDL_Surface * screen;
+
+ /**
+ * Get an object's X coordinate as pixels
+diff --git a/src/utils.h b/src/utils.h
+index 9b0b155..2018969 100644
+--- a/src/utils.h
++++ b/src/utils.h
+@@ -87,7 +87,7 @@
+ extern char *progpath;
+ extern char *langpath;
+
+-SDL_Surface * screen;
++extern SDL_Surface * screen;
+
+ int get_x(int x);
+ int get_y(int y);