summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox/dosbox-9999.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild33
1 files changed, 20 insertions, 13 deletions
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index f0caa33b0f3c..97c581f2f198 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -1,17 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
-inherit autotools eutils subversion games
+EAPI=6
+
+if [[ ${PV} = 9999 ]]; then
+ ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
+ inherit subversion
+else
+ SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit autotools eutils
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="alsa debug hardened opengl"
DEPEND="alsa? ( media-libs/alsa-lib )
@@ -23,19 +30,20 @@ DEPEND="alsa? ( media-libs/alsa-lib )
media-libs/sdl-sound"
RDEPEND=${DEPEND}
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- subversion_src_unpack
-}
+if [[ ${PV} = 9999 ]]; then
+ S=${WORKDIR}/${PN}
+fi
src_prepare() {
- subversion_src_prepare
+ default
+ if [[ ${PV} = 9999 ]]; then
+ subversion_src_prepare
+ fi
eautoreconf
}
src_configure() {
- egamesconf \
+ econf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
@@ -47,5 +55,4 @@ src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
- prepgamesdirs
}