summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/fbzx')
-rw-r--r--games-emulation/fbzx/Manifest1
-rw-r--r--games-emulation/fbzx/fbzx-2.10.0.ebuild38
-rw-r--r--games-emulation/fbzx/files/fbzx-2.10.0-build.patch12
-rw-r--r--games-emulation/fbzx/files/fbzx-2.10.0-keyboard.patch11
-rw-r--r--games-emulation/fbzx/metadata.xml9
5 files changed, 71 insertions, 0 deletions
diff --git a/games-emulation/fbzx/Manifest b/games-emulation/fbzx/Manifest
new file mode 100644
index 000000000000..6fc69fbcd565
--- /dev/null
+++ b/games-emulation/fbzx/Manifest
@@ -0,0 +1 @@
+DIST fbzx-2.10.0.tar.bz2 326352 SHA256 deed3d37247e4154bb10325d014461c8caf0c55ca23a611c62035e491a4f960f SHA512 b96ae4029e4ef73d15c851a54c8e057131ba6e0acf03820222aa4d4bc91e8ad497556cce41c5faef230939f1c88423e09e435f9ce91c0e0f183f6eac7843bb36 WHIRLPOOL 97bb0fcbb9d1c5921b7c6f9d4873fd620d2219b71abbaece2453f4417bace91c1b1fab44382f2d63b5aa8c3225f5f865150b51ce534a228712a39543912ea908
diff --git a/games-emulation/fbzx/fbzx-2.10.0.ebuild b/games-emulation/fbzx/fbzx-2.10.0.ebuild
new file mode 100644
index 000000000000..3dfff4c8a209
--- /dev/null
+++ b/games-emulation/fbzx/fbzx-2.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer"
+HOMEPAGE="http://www.rastersoft.com/fbzx.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[video]
+ media-sound/pulseaudio
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s|/usr/share/|${GAMES_DATADIR}/${PN}/|g" emulator.c || die
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-keyboard.patch
+}
+
+src_install() {
+ dogamesbin fbzx
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r keymap.bmp spectrum-roms
+ dodoc AMSTRAD CAPABILITIES FAQ PORTING README* TODO VERSIONS
+ doicon fbzx.svg
+ make_desktop_entry fbzx FBZX
+ prepgamesdirs
+}
diff --git a/games-emulation/fbzx/files/fbzx-2.10.0-build.patch b/games-emulation/fbzx/files/fbzx-2.10.0-build.patch
new file mode 100644
index 000000000000..191e7f09ac1e
--- /dev/null
+++ b/games-emulation/fbzx/files/fbzx-2.10.0-build.patch
@@ -0,0 +1,12 @@
+diff -ru fbzx-2.10.0.orig/Makefile fbzx-2.10.0/Makefile
+--- fbzx-2.10.0.orig/Makefile 2012-06-22 19:44:32.000000000 -0400
++++ fbzx-2.10.0/Makefile 2012-08-11 03:08:12.761127099 -0400
+@@ -4,7 +4,7 @@
+ PREFIX2=/usr/local
+ endif
+
+-CFLAGS += `pkg-config --cflags sdl libpulse-simple alsa` -O2 -Wno-pointer-sign -Wall -D D_SOUND_PULSE -D D_SOUND_ALSA -D D_SOUND_OSS
++CFLAGS += `pkg-config --cflags sdl libpulse-simple alsa` -Wno-pointer-sign -Wall -D D_SOUND_PULSE -D D_SOUND_ALSA -D D_SOUND_OSS
+ LDFLAGS += `pkg-config --libs sdl libpulse-simple alsa`
+
+ fbzx: computer.o Z80free.o Z80free_codes.o Z80free_codesCB.o Z80free_codesED.o Z80free_codesDD.o Z80free_codesFD.o Z80free_codesDDCB.o Z80free_codesFDCB.o emulator.o cargador.o characters.o menus.o sound.o tape.o spk_ay.o microdrive.o
diff --git a/games-emulation/fbzx/files/fbzx-2.10.0-keyboard.patch b/games-emulation/fbzx/files/fbzx-2.10.0-keyboard.patch
new file mode 100644
index 000000000000..3920748c07e9
--- /dev/null
+++ b/games-emulation/fbzx/files/fbzx-2.10.0-keyboard.patch
@@ -0,0 +1,11 @@
+--- menus.c.orig
++++ menus.c
+@@ -1820,7 +1820,7 @@
+ buffer=screen->pixels;
+
+ clean_screen();
+- fichero=myfopen("fbzx/keymap.bmp","r");
++ fichero=myfopen("keymap.bmp","r");
+ if (fichero==NULL) {
+ strcpy(ordenador.osd_text,"Keymap picture not found");
+ ordenador.osd_time=100;
diff --git a/games-emulation/fbzx/metadata.xml b/games-emulation/fbzx/metadata.xml
new file mode 100644
index 000000000000..b2e8a5cecf47
--- /dev/null
+++ b/games-emulation/fbzx/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+ FBZX is a Sinclair Spectrum emulator, designed to work at full screen
+ using the FrameBuffer.
+ </longdescription>
+</pkgmetadata>