summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/m64py')
-rw-r--r--games-emulation/m64py/Manifest2
-rw-r--r--games-emulation/m64py/files/m64py-0.2.5_p20211222-setuptools-69.patch17
-rw-r--r--games-emulation/m64py/m64py-0.2.5_p20211222.ebuild (renamed from games-emulation/m64py/m64py-0.2.5.ebuild)43
-rw-r--r--games-emulation/m64py/metadata.xml3
4 files changed, 55 insertions, 10 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
index 36736dbfddfb..a4abed5c706d 100644
--- a/games-emulation/m64py/Manifest
+++ b/games-emulation/m64py/Manifest
@@ -1 +1 @@
-DIST m64py-0.2.5.tar.gz 201868 BLAKE2B 95cbfe58ae2741caac5e05bcc06af563ee398d2916d07902ba4aaf4213277eea3c6219448db5958e0a2d0ea8ea3f65c88e63cfd2938a8b4ed33231ba57ae724f SHA512 338f5e96dc4657ba2230c32a40cf0e85c5efcccaa0d5fdbe4b4dcef020b910f5d2d88e5c224f8b496ec0378051aaf44358a0438de52fb03b4ece353f55abc61c
+DIST mupen64plus-ui-python-e24679436a93e8aae0aa664dc4b2dea40d8236c1.gh.tar.gz 14669412 BLAKE2B 08232599557503d606db9e44bdd6dbb30b3fa125bfd9b9bcc2cbc4b6ea71b567f5af4338d03e7580707db522249d9426ec4d64dc1e941a43076b2d21bc974b67 SHA512 2ba865041827a7f47d5151db6123abd62c964c024c14356aa5434619736b19ce150178d536cff1c84e93d0544823e173c67c0f08054c13e01f085912a9b8c2c6
diff --git a/games-emulation/m64py/files/m64py-0.2.5_p20211222-setuptools-69.patch b/games-emulation/m64py/files/m64py-0.2.5_p20211222-setuptools-69.patch
new file mode 100644
index 000000000000..cb61839776e0
--- /dev/null
+++ b/games-emulation/m64py/files/m64py-0.2.5_p20211222-setuptools-69.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index b68b6e3..270291d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -15,6 +15,12 @@ import distutils.command.build as distutils_build
+ import distutils.command.clean as distutils_clean
+ import setuptools
+
++try:
++ import setuptools.modified
++ distutils.dep_util = setuptools.modified
++except ImportError:
++ pass
++
+ # Add the src folder to the path
+ sys.path.insert(0, os.path.realpath("src"))
+
diff --git a/games-emulation/m64py/m64py-0.2.5.ebuild b/games-emulation/m64py/m64py-0.2.5_p20211222.ebuild
index b870229f5b8e..2b4004c0ee48 100644
--- a/games-emulation/m64py/m64py-0.2.5.ebuild
+++ b/games-emulation/m64py/m64py-0.2.5_p20211222.ebuild
@@ -1,15 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 xdg-utils
+inherit distutils-r1 qmake-utils xdg-utils
+
+EGIT_COMMIT="e24679436a93e8aae0aa664dc4b2dea40d8236c1"
+MY_P=mupen64plus-ui-python-${EGIT_COMMIT}
DESCRIPTION="A frontend for Mupen64Plus"
-HOMEPAGE="http://m64py.sourceforge.net/"
-SRC_URI="https://downloads.sourceforge.net/project/m64py/${P}/${P}.tar.gz"
+HOMEPAGE="
+ https://m64py.sourceforge.net/
+ https://github.com/mupen64plus/mupen64plus-ui-python/
+"
+SRC_URI="
+ https://github.com/mupen64plus/mupen64plus-ui-python/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
SLOT="0"
@@ -21,16 +32,27 @@ RDEPEND="
dev-python/PySDL2[${PYTHON_USEDEP}]
media-libs/libsdl2[joystick,video]
>=games-emulation/mupen64plus-core-2.5:0/2-sdl2
- 7z? ( app-arch/p7zip )
+ 7z? (
+ app-arch/p7zip
+ )
rar? (
|| (
dev-python/rarfile[${PYTHON_USEDEP}]
app-arch/unrar
app-arch/rar
)
- )"
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
python_prepare_all() {
+ local PATCHES=(
+ # https://github.com/mupen64plus/mupen64plus-ui-python/issues/227
+ "${FILESDIR}/${P}-setuptools-69.patch"
+ )
+
# set the correct search path
cat >> src/m64py/platform.py <<-_EOF_ || die
SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
@@ -39,6 +61,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_compile() {
+ local -x PATH=$(qt5_get_bindir):${PATH}
+ distutils-r1_python_compile
+}
+
pkg_postinst() {
xdg_desktop_database_update
}
diff --git a/games-emulation/m64py/metadata.xml b/games-emulation/m64py/metadata.xml
index bfcd7dbfd100..496bf0b01942 100644
--- a/games-emulation/m64py/metadata.xml
+++ b/games-emulation/m64py/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mgorny@gentoo.org</email>
@@ -10,6 +10,7 @@
<flag name="rar">Ensure support for .rar archives.</flag>
</use>
<upstream>
+ <remote-id type="github">mupen64plus/mupen64plus-ui-python</remote-id>
<remote-id type="sourceforge">m64py</remote-id>
</upstream>
</pkgmetadata>