summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/snes9x/Manifest1
-rw-r--r--games-emulation/snes9x/snes9x-1.53.ebuild119
2 files changed, 0 insertions, 120 deletions
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index cccfb90e5385..5a8ef1263f05 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -1,2 +1 @@
-DIST snes9x-1.53-src.tar.bz2 1838746 BLAKE2B 09fffb48d59f172b2e08b2f20c073c7d0acd1b8108c986938eaa3283791f9362c7d2e0db5563f6097606650de0327ea3a8d0fcac4d73c326c922442ab539cc49 SHA512 3ded506d1b3b6cff4e8e3de77ad557d97981eb97ea23ffc68ce5abbbd4677aca819776f1d11b9aa47f5b1a785b19455acf6ad4dbc536d3581d62c192ebdfbd8c
DIST snes9x-1.54.1.tar.gz 2186737 BLAKE2B b433a167035577ab785901acb65b9df289218fa214f664494e7f0559a1a843c9211f81bfea3add73c64c6f87e974b0964a86fa43433fa1b5c6e20a724d3aa320 SHA512 2a8fddc0b9044c0b7e10711b35c06555e280c93ddde3c101c4084f859079947acb209f2632ca08937fa2ca47932094040c4a7a60b6188354fd92f72dbdf854ed
diff --git a/games-emulation/snes9x/snes9x-1.53.ebuild b/games-emulation/snes9x/snes9x-1.53.ebuild
deleted file mode 100644
index 900716e81c40..000000000000
--- a/games-emulation/snes9x/snes9x-1.53.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils flag-o-matic multilib gnome2-utils games
-
-DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
-HOMEPAGE="https://code.google.com/p/snes9x-gtk/"
-SRC_URI="https://snes9x-gtk.googlecode.com/files/${P}-src.tar.bz2"
-
-LICENSE="Snes9x GPL-2 GPL-2+ LGPL-2.1 LGPL-2.1+ ISC MIT ZLIB Info-ZIP"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
-IUSE="alsa debug gtk joystick multilib netplay nls opengl oss png pulseaudio portaudio +xv +xrandr zlib"
-RESTRICT="bindist"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- png? ( >=media-libs/libpng-1.2.43:0 )
- gtk? ( >=x11-libs/gtk+-2.10:2
- x11-misc/xdg-utils
- portaudio? ( >=media-libs/portaudio-19_pre )
- joystick? ( >=media-libs/libsdl-1.2.12[joystick] )
- opengl? ( virtual/opengl )
- xv? ( x11-libs/libXv )
- xrandr? ( x11-libs/libXrandr )
- alsa? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio ) )"
-DEPEND="${RDEPEND}
- x11-proto/xproto
- gtk? ( virtual/pkgconfig
- xv? ( x11-proto/videoproto ) )
- nls? ( dev-util/intltool )"
-
-S=${WORKDIR}/${P}-src/unix
-
-pkg_setup() {
- games_pkg_setup
-}
-
-src_prepare() {
- cd "${WORKDIR}"/${P}-src
- sed -i -e '/pedantic/d' {gtk,unix}/configure.ac || die
- sed -i -e '75i#define OF(x) x' unzip/{un,}zip.h || die
- sed -i -e '22i#define OF(x) x' unzip/ioapi.h || die
- epatch "${FILESDIR}"/${P}-build.patch
- epatch "${FILESDIR}"/${P}-cross-compile.patch
- cd unix
- eautoreconf
- if use gtk; then
- cd ../gtk
- eautoreconf
- fi
-}
-
-src_configure() {
- append-ldflags -Wl,-z,noexecstack
-
- egamesconf \
- $(use_enable joystick gamepad) \
- $(use_enable debug debugger) \
- $(use_enable netplay) \
- $(use_enable zlib gzip) \
- $(use_enable zlib zip) \
- $(use_enable png screenshot)
-
- if use gtk; then
- cd ../gtk
- egamesconf \
- --datadir=/usr/share \
- $(use_enable nls) \
- $(use_with opengl) \
- $(use_with joystick) \
- $(use_with xv) \
- $(use_with xrandr) \
- $(use_with netplay) \
- $(use_with zlib) \
- $(use_with alsa) \
- $(use_with oss) \
- $(use_with pulseaudio) \
- $(use_with portaudio) \
- $(use_with png screenshot)
- fi
-}
-
-src_compile() {
- games_src_compile
- if use gtk; then
- emake -C ../gtk
- fi
-}
-
-src_install() {
- dogamesbin ${PN}
-
- dohtml {.,..}/docs/*.html
- dodoc ../docs/{snes9x.conf.default,{changes,control-inputs,controls,snapshots}.txt}
-
- if use gtk; then
- emake -C ../gtk DESTDIR="${D}" install
- dodoc ../gtk/{AUTHORS,doc/README}
- fi
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- use gtk && gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- use gtk && gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- use gtk && gnome2_icon_cache_update
-}