summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gcube/gcube-0.4-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/games-emulation/gcube/gcube-0.4-r1.ebuild b/games-emulation/gcube/gcube-0.4-r1.ebuild
index 716caf3138f8..19b5b5f2a43a 100644
--- a/games-emulation/gcube/gcube-0.4-r1.ebuild
+++ b/games-emulation/gcube/gcube-0.4-r1.ebuild
@@ -1,35 +1,35 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils games
+inherit eutils flag-o-matic games
DESCRIPTION="Gamecube emulator"
HOMEPAGE="http://gcube.exemu.net/"
SRC_URI="http://gcube.exemu.net/downloads/${P}-src.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
DEPEND="virtual/opengl
- media-libs/libsdl[sound,joystick,video]
+ media-libs/libsdl[joystick,opengl,sound,video]
virtual/jpeg:0
sys-libs/ncurses:0
sys-libs/zlib"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
S=${WORKDIR}/${PV}
src_prepare() {
- sed -i \
- -e '/^CFLAGS=-g/d' Makefile.rules \
- || die "sed failed"
+ sed -i -e '/^CFLAGS=-g/d' Makefile.rules || die
epatch "${FILESDIR}"/${P}-ldflags.patch \
"${FILESDIR}"/${P}-underlink.patch \
"${FILESDIR}"/${P}-gcc47.patch
+ sed -i -e '/^CC=/d' Makefile || die
+ append-cflags -std=gnu89 # build with gcc5 (bug #570504)
}
src_install() {