summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/m64py/m64py-0.2.4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-emulation/m64py/m64py-0.2.4.ebuild b/games-emulation/m64py/m64py-0.2.4.ebuild
index bd849bbab87a..3a2bbf163379 100644
--- a/games-emulation/m64py/m64py-0.2.4.ebuild
+++ b/games-emulation/m64py/m64py-0.2.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 xdg-utils
@@ -37,9 +37,9 @@ RDEPEND="
python_prepare_all() {
# set the correct search path
- cat >> src/m64py/platform.py <<-_EOF_
+ cat >> src/m64py/platform.py <<-_EOF_ || die
SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
-_EOF_
+ _EOF_
distutils-r1_python_prepare_all
}