summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/Manifest1
-rw-r--r--games-emulation/stella/stella-4.0.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index 84288b9321c2..f3e43e672a74 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,2 +1 @@
-DIST stella-4.0-src.tar.gz 2283736 BLAKE2B bbc95e6c073ced1a2d79a135432f2bd11656dfdb5ab468c581df138438e6f1b0e792f5b68db26ba5aefb0ec3ff9567a2ab75a5021571b80895ce1c9987a19407 SHA512 42df4429dfbfc268e7b7d1c538641b443703ba2af4ad4e66b9df05f2b7d62a860a1895f738d95a3a0b879052865137d31a22b8611f3b93ff9746649553c099fa
DIST stella-4.7.2-src.tar.xz 1715332 BLAKE2B 7b397a4e662f8db247a67ddedb314c9b11ee4e99d55768b1cd8e2587b452fab9c5d45c840bf1577833712a2c96d42985d39437d1fac16e93c35762e015ddf445 SHA512 dcfaba9b554ab08c9ba79c8e95551bc688fae4ab0ab368df11c05f3dc7c9431d32068d5dd658ec4d1aa8cb826c7205fc4f301145a149d32369833409992455e2
diff --git a/games-emulation/stella/stella-4.0.ebuild b/games-emulation/stella/stella-4.0.ebuild
deleted file mode 100644
index 5cf6b70c7e9e..000000000000
--- a/games-emulation/stella/stella-4.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils gnome2-utils games
-
-DESCRIPTION="Stella Atari 2600 VCS Emulator"
-HOMEPAGE="http://stella.sourceforge.net/"
-SRC_URI="mirror://sourceforge/stella/${P}-src.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="joystick"
-
-DEPEND="media-libs/libsdl2[joystick?,opengl,video]
- media-libs/libpng:0
- sys-libs/zlib"
-RDEPEND=${DEPEND}
-
-src_prepare() {
- sed -i \
- -e '/INSTALL/s/-s //' \
- -e '/STRIP/d' \
- -e "/icons/d" \
- -e '/INSTALL.*DOCDIR/d' \
- -e '/INSTALL.*\/applications/d' \
- -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
- Makefile || die
-}
-
-src_configure() {
- # not an autoconf script
- ./configure \
- --prefix="/usr" \
- --bindir="${GAMES_BINDIR}" \
- --docdir="/usr/share/doc/${PF}" \
- --datadir="${GAMES_DATADIR}" \
- $(use_enable joystick) \
- || die
-}
-
-src_install() {
- local i
- for i in 16 22 24 32 48 64 128 ; do
- newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
- done
-
- emake DESTDIR="${D}" install
- domenu src/unix/stella.desktop
- dohtml -r docs/*
- dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}