summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/frobtads/frobtads-1.2.4.ebuild')
-rw-r--r--games-engines/frobtads/frobtads-1.2.4.ebuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/games-engines/frobtads/frobtads-1.2.4.ebuild b/games-engines/frobtads/frobtads-1.2.4.ebuild
index 7f2b43c14462..f0fd3816a632 100644
--- a/games-engines/frobtads/frobtads-1.2.4.ebuild
+++ b/games-engines/frobtads/frobtads-1.2.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
+
+inherit autotools
DESCRIPTION="Curses-based interpreter and dev tools for TADS 2 and TADS 3 text adventures"
HOMEPAGE="http://www.tads.org/frobtads.htm"
@@ -16,17 +17,28 @@ IUSE="debug tads2compiler tads3compiler"
RESTRICT="!tads3compiler? ( test )"
RDEPEND="net-misc/curl
- sys-libs/ncurses:0"
-DEPEND=${RDEPEND}
+ sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.4-tinfo.patch #602446
+)
+
+src_prepare() {
+ default
+ eautoreconf #602446
+}
+
src_configure() {
- econf \
- $(use_enable debug error-checking) \
- $(use_enable debug t3debug) \
- $(use_enable tads2compiler t2-compiler) \
+ local myeconfargs=(
+ $(use_enable debug error-checking)
+ $(use_enable debug t3debug)
+ $(use_enable tads2compiler t2-compiler)
$(use_enable tads3compiler t3-compiler)
+ )
+ econf "${myeconfargs[@]}"
}
src_test() {