summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/devilutionx/Manifest1
-rw-r--r--games-engines/devilutionx/devilutionx-1.5.2.ebuild89
-rw-r--r--games-engines/exult/Manifest2
-rw-r--r--games-engines/exult/exult-1.10.1.ebuild (renamed from games-engines/exult/exult-1.8.ebuild)0
-rw-r--r--games-engines/fheroes2/Manifest3
-rw-r--r--games-engines/fheroes2/fheroes2-1.1.1.ebuild76
-rw-r--r--games-engines/fheroes2/fheroes2-1.1.3.ebuild (renamed from games-engines/fheroes2/fheroes2-1.1.2.ebuild)1
-rw-r--r--games-engines/odamex/files/odamex-10.6.0-odalaunch-sorting-crash.patch28
-rw-r--r--games-engines/odamex/odamex-10.6.0-r1.ebuild89
-rw-r--r--games-engines/openmw/files/openmw-0.48.0-Xt.patch17
-rw-r--r--games-engines/openmw/files/openmw-0.48.0-gcc14.patch10
-rw-r--r--games-engines/openmw/openmw-0.48.0.ebuild1
-rw-r--r--games-engines/openmw/openmw-9999.ebuild70
13 files changed, 192 insertions, 195 deletions
diff --git a/games-engines/devilutionx/Manifest b/games-engines/devilutionx/Manifest
index 299e15cb86fe..cce23aa680f0 100644
--- a/games-engines/devilutionx/Manifest
+++ b/games-engines/devilutionx/Manifest
@@ -1,2 +1 @@
-DIST devilutionx-1.5.2.tar.xz 21968848 BLAKE2B 5a8c280f262e2d0f47ee5978cfc858ea62481eac838ad691996f359f1c4889499e4c78b5e6a1f2dc998cf0fc89ebbdf79296a25adb411e30e9248cce1b07d3a8 SHA512 b7fd5814c8671e439d4349297cfda0d89eb1f7a0945ec11bdf7a83637371664c9c39c036249e1650911397111e1b5d9e931f221ffd2d4a1f9e80d5ca58357dcf
DIST devilutionx-1.5.3.tar.xz 22394112 BLAKE2B 1b04c7fe334ddfd6b1eb619b1e86c1e429f6c26c980a16129d8322bb30641409d9d11a203e42ccdbce60a05e00dc49b1a2acbdd1007c5f99e40b88acd1251440 SHA512 619873bb232d1b344f5001c232364af9cfcda72e44f28fd2a15332292fa37c0e64b7fccade3570b96bd648be235ed56e0cc2e3fd8299ac57ef26f2ce844cbc2f
diff --git a/games-engines/devilutionx/devilutionx-1.5.2.ebuild b/games-engines/devilutionx/devilutionx-1.5.2.ebuild
deleted file mode 100644
index 29c272d0006a..000000000000
--- a/games-engines/devilutionx/devilutionx-1.5.2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-DESCRIPTION="Diablo engine for modern operating systems"
-HOMEPAGE="https://github.com/diasurgical/devilutionX/"
-SRC_URI="
- https://github.com/diasurgical/devilutionX/releases/download/${PV}/devilutionx-src.tar.xz
- -> ${P}.tar.xz
-"
-S=${WORKDIR}/${PN}-src-${PV}
-
-LICENSE="Unlicense CC-BY-4.0 GPL-2+ LGPL-2.1+ MIT OFL-1.1 zerotier? ( BUSL-1.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug +sodium test zerotier"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/bzip2:=
- dev-libs/libfmt:=
- media-libs/libsdl2[haptic,joystick,opengl,video]
- media-libs/sdl2-image[png]
- media-libs/sdl_audiolib
- sys-libs/zlib:=
- sodium? ( dev-libs/libsodium:= )
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/asio
- dev-cpp/simpleini
- test? ( dev-cpp/gtest )
-"
-BDEPEND="
- sys-devel/gettext
-"
-
-src_prepare() {
- cmake_src_prepare
-
- # use system asio
- echo 'add_library(asio INTERFACE)' > 3rdParty/asio/CMakeLists.txt || die
-
- # ensure system copies are used
- rm -r dist/{asio,simpleini,sdl_audiolib}-src || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test)
- -DCCACHE_PROGRAM=no #813768
- -DDEBUG=$(usex debug)
- -DDISABLE_LTO=yes # let CFLAGS control this
- -DDISABLE_ZERO_TIER=$(usex !zerotier)
- -DPACKET_ENCRYPTION=$(usex sodium)
- -DPIE=yes
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # timedemo tests only pass when game assets are available
- cmake_src_test -E Timedemo.
-}
-
-src_install() {
- local DOCS=( Packaging/nix/README.txt docs/*.md )
- cmake_src_install
-
- rm -- "${ED}"/usr/share/diasurgical/devilutionx/README.txt || die
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "In order to play the game, you will need to copy the following data file"
- elog "from the original game, and optionally the hellfire expansion files:"
- elog " - DIABDAT.MPQ"
- elog " - hellfire.mpq hfmonk.mpq hfmusic.mpq hfvoice.mpq"
- elog "to ~/.local/share/diasurgical/devilution/"
- elog
- elog "See ${EROOT}/usr/share/doc/${PF}/README.txt* for details."
- fi
-}
diff --git a/games-engines/exult/Manifest b/games-engines/exult/Manifest
index c7d793a45880..264976543329 100644
--- a/games-engines/exult/Manifest
+++ b/games-engines/exult/Manifest
@@ -1 +1 @@
-DIST exult-1.8.tar.gz 19104130 BLAKE2B 56e127d95d3a948b7c52ca3439f8a84691728817c855b46580a8baf21ad0b8f663d5f9fb2fb855d73baa1d3cc29181d001adae1a978c75a7dfa598879b559ab4 SHA512 5422f70c00a1d5ff0606cb7613b891abda430872c50b1058999085c7df08360fd55d5bdf95cbff09616cf3b11e51dce4b11c7322c3db9a8756946e5854ef0fde
+DIST exult-1.10.1.tar.gz 19688644 BLAKE2B 82f8f9c590d29844cb12cf56939d6aaea65cb42a3b0e507d4e5727febbd3e5037c81064528a4cddb8e064ca4a47622c1be64c66e7bed8afe3de48d7d9a94beb9 SHA512 fc17e4d6f0fdc121f5a201508b20902d12858f227d14413b393ad8b9cfcc72a85c2cff35b502dc9e7525f7860bf663c6daca0f6680ab15e3a9f90d4db3a7ec2c
diff --git a/games-engines/exult/exult-1.8.ebuild b/games-engines/exult/exult-1.10.1.ebuild
index 009f8a97d9b2..009f8a97d9b2 100644
--- a/games-engines/exult/exult-1.8.ebuild
+++ b/games-engines/exult/exult-1.10.1.ebuild
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index 3378b940ebb7..3e3b03e8874b 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1,2 +1 @@
-DIST fheroes2-1.1.1.tar.gz 12212585 BLAKE2B 0adc66e83c86c0b0535ad4dead0dc8157dbf69b683e2f1d0ef737bff6b3780bd9ed09bd99a4a168a6f8bd8fdf2672b8f2cfd06bf739b53222510673189572a28 SHA512 08aceb9755558516eb747f13b0c4e442786a9a818120e077de6d6921b6fb7e44c440b94447d36c7c735d3670656259b49eac6965656352590d58572756ed7990
-DIST fheroes2-1.1.2.tar.gz 12226373 BLAKE2B 191710016c9b32b748315a548fe6309012917d690625b968b2f30afae50507eb736ef6dab4f71c3dae9e1d14b69e93fa0ae0a7cc8770f81e6a8d09e390117a3a SHA512 31bb63f4a8a7a58894ae0f5e28bb1cae0745a5cee475aa78eded20ad8c39fe6fb23bea3596215167fe042405509b08691234ec4a51a2a8367386a88b3e664659
+DIST fheroes2-1.1.3.tar.gz 12247780 BLAKE2B 28252ba6ccb5d4fbce1dfa4a456a64a8fbb5f763602ed0e1c1a20bebfae659ab694085bbb7ffcf79396b54bd2bba94fe00b92064756094ce20fe74808fc09eec SHA512 56ce526f265b7995a8ee2e964937802b284b8df56298f2e755b93ce3f52f1ba6d5265ecc3d33ed020bff06707c5dd55a8057e1c9e3de9f241f6edae397220b1d
diff --git a/games-engines/fheroes2/fheroes2-1.1.1.ebuild b/games-engines/fheroes2/fheroes2-1.1.1.ebuild
deleted file mode 100644
index c54e921e38d6..000000000000
--- a/games-engines/fheroes2/fheroes2-1.1.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake python-single-r1 xdg
-
-DESCRIPTION="Recreation of HoMM2 game engine"
-HOMEPAGE="https://ihhub.github.io/fheroes2/"
-SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-IUSE="tools"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- media-libs/libpng:=
- media-libs/libsdl2[video]
- media-libs/sdl2-image
- media-libs/sdl2-mixer
- sys-libs/zlib
-"
-RDEPEND="
- ${DEPEND}
- ${PYTHON_DEPS}
- app-arch/libarchive
- dev-lang/python
- virtual/libintl
-"
-BDEPEND="
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
-)
-
-src_configure() {
- # Not using dev-games/libsmacker because the game crashes with it
- local mycmakeargs=(
- -DENABLE_IMAGE=ON
- -DENABLE_TOOLS=$(usex tools)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- emake -C files/lang
-}
-
-src_install() {
- cmake_src_install
-
- if use tools; then
- for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
- newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
- done
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog "You need original HoMM2 data files to play fheroes2."
- elog "If you have an installer (.exe) from GOG, install:"
- elog " games-strategy/homm2-gold-gog"
- elog "If you have the original game installed somewhere already, run:"
- elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
- elog "Also you can automatically get a demo version for free by installing:"
- elog " games-strategy/homm2-demo"
-}
diff --git a/games-engines/fheroes2/fheroes2-1.1.2.ebuild b/games-engines/fheroes2/fheroes2-1.1.3.ebuild
index 193d6d4fc211..20ce7e8e3312 100644
--- a/games-engines/fheroes2/fheroes2-1.1.2.ebuild
+++ b/games-engines/fheroes2/fheroes2-1.1.3.ebuild
@@ -27,7 +27,6 @@ RDEPEND="
${DEPEND}
${PYTHON_DEPS}
app-arch/libarchive
- dev-lang/python
virtual/libintl
"
BDEPEND="
diff --git a/games-engines/odamex/files/odamex-10.6.0-odalaunch-sorting-crash.patch b/games-engines/odamex/files/odamex-10.6.0-odalaunch-sorting-crash.patch
new file mode 100644
index 000000000000..b665d16d86a4
--- /dev/null
+++ b/games-engines/odamex/files/odamex-10.6.0-odalaunch-sorting-crash.patch
@@ -0,0 +1,28 @@
+From e8dfbdc08a58d709fa7c23e38911c421cdb2a76d Mon Sep 17 00:00:00 2001
+From: Pavel Miksha <89637241+keyboardcrash32@users.noreply.github.com>
+Date: Sun, 20 Oct 2024 15:53:14 +0300
+Subject: [PATCH] Fix odalaunch crashing when sorting servers
+
+---
+ odalaunch/src/lst_custom.cpp | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/odalaunch/src/lst_custom.cpp b/odalaunch/src/lst_custom.cpp
+index 1ad0387fa..22182b6cb 100644
+--- a/odalaunch/src/lst_custom.cpp
++++ b/odalaunch/src/lst_custom.cpp
+@@ -319,6 +319,14 @@ int wxCALLBACK wxCompareFunction(wxIntPtr item1, wxIntPtr item2,
+ Item.SetColumn(SortCol);
+ Item.SetMask(wxLIST_MASK_TEXT);
+
++ long id1 = ListCtrl->FindItem(-1, item1);
++ long id2 = ListCtrl->FindItem(-1, item2);
++
++ if (id1 == -1 || id2 == -1)
++ {
++ return 0;
++ }
++
+ if(SortCol == ListCtrl->GetSpecialSortColumn())
+ {
+ int Img1, Img2;
diff --git a/games-engines/odamex/odamex-10.6.0-r1.ebuild b/games-engines/odamex/odamex-10.6.0-r1.ebuild
new file mode 100644
index 000000000000..504ec274d098
--- /dev/null
+++ b/games-engines/odamex/odamex-10.6.0-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit cmake desktop prefix wxwidgets xdg
+
+DESCRIPTION="Online multiplayer free software engine for DOOM"
+HOMEPAGE="https://odamex.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${PN}-src-${PV}.tar.xz"
+S="${WORKDIR}/${PN}-src-${PV}"
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="+client hidpi master +odalaunch portmidi server upnp"
+REQUIRED_USE="|| ( client master server )"
+
+# protobuf is still bundled. Unfortunately an old version is required for C++98
+# compatibility. We could use C++11, but upstream is concerned about using a
+# completely different protobuf version on a multiplayer-focused engine.
+
+RDEPEND="
+ client? (
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/sdl2-mixer
+ net-misc/curl
+ x11-libs/libX11
+ !hidpi? ( x11-libs/fltk:1 )
+ portmidi? ( media-libs/portmidi )
+ )
+ odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER} )
+ server? (
+ dev-libs/jsoncpp:=
+ upnp? ( net-libs/miniupnpc:= )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="games-util/deutex"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-10.3.0-unbundle-fltk.patch
+ "${FILESDIR}"/${P}-odalaunch-sorting-crash.patch
+)
+
+src_prepare() {
+ rm -r libraries/miniupnp || die
+ hprefixify common/d_main.cpp
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ use odalaunch && setup-wxwidgets
+
+ local mycmakeargs=(
+ -DUSE_INTERNAL_FLTK=$(usex hidpi)
+ -DUSE_INTERNAL_JSONCPP=0
+ -DUSE_INTERNAL_LIBS=0
+ -DUSE_INTERNAL_MINIUPNP=0
+ -DBUILD_CLIENT=$(usex client)
+ -DBUILD_LAUNCHER=$(usex odalaunch)
+ -DBUILD_MASTER=$(usex master)
+ -DBUILD_SERVER=$(usex server)
+ -DBUILD_OR_FAIL=1
+ -DENABLE_PORTMIDI=$(usex portmidi)
+ -DUSE_MINIUPNP=$(usex upnp)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ if use client ; then
+ for size in 96 128 256 512; do
+ newicon -s ${size} "${S}/media/icon_${PN}_${size}.png" "${PN}.png"
+ done
+ make_desktop_entry "${PN}" "Odamex"
+
+ if use odalaunch ; then
+ for size in 96 128 256 512; do
+ newicon -s ${size} "${S}/media/icon_odalaunch_${size}.png" "odalaunch.png"
+ done
+ make_desktop_entry odalaunch "Odamex Launcher" odalaunch
+ fi
+ fi
+
+ cmake_src_install
+}
diff --git a/games-engines/openmw/files/openmw-0.48.0-Xt.patch b/games-engines/openmw/files/openmw-0.48.0-Xt.patch
new file mode 100644
index 000000000000..e24516af9155
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.48.0-Xt.patch
@@ -0,0 +1,17 @@
+https://gitlab.com/OpenMW/openmw/-/merge_requests/4407
+https://bugs.gentoo.org/925582
+
+--- a/apps/wizard/CMakeLists.txt
++++ b/apps/wizard/CMakeLists.txt
+@@ -98,11 +98,6 @@ if (BUILD_WITH_CODE_COVERAGE)
+ target_link_libraries(openmw-wizard gcov)
+ endif()
+
+-# Workaround for binutil => 2.23 problem when linking, should be fixed eventually upstream
+-if (CMAKE_SYSTEM_NAME MATCHES "Linux")
+-target_link_libraries(openmw-wizard dl Xt)
+-endif()
+-
+ if (WIN32)
+ INSTALL(TARGETS openmw-wizard RUNTIME DESTINATION ".")
+ endif(WIN32)
diff --git a/games-engines/openmw/files/openmw-0.48.0-gcc14.patch b/games-engines/openmw/files/openmw-0.48.0-gcc14.patch
index 423aea9734af..d1214339ee2d 100644
--- a/games-engines/openmw/files/openmw-0.48.0-gcc14.patch
+++ b/games-engines/openmw/files/openmw-0.48.0-gcc14.patch
@@ -22,3 +22,13 @@ https://bugs.gentoo.org/925105
#include <boost/filesystem/path.hpp>
#include "character.hpp"
+--- a/apps/openmw_test_suite/nifloader/testbulletnifloader.cpp
++++ b/apps/openmw_test_suite/nifloader/testbulletnifloader.cpp
+@@ -13,6 +13,7 @@
+
+ #include <algorithm>
+ #include <type_traits>
++#include <iomanip>
+
+ namespace
+ {
diff --git a/games-engines/openmw/openmw-0.48.0.ebuild b/games-engines/openmw/openmw-0.48.0.ebuild
index 65765800e7b5..0ca8e595f5d7 100644
--- a/games-engines/openmw/openmw-0.48.0.ebuild
+++ b/games-engines/openmw/openmw-0.48.0.ebuild
@@ -76,6 +76,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/openmw-0.48.0-gcc14.patch"
+ "${FILESDIR}/openmw-0.48.0-Xt.patch"
)
src_prepare() {
diff --git a/games-engines/openmw/openmw-9999.ebuild b/games-engines/openmw/openmw-9999.ebuild
index b1a63beee240..ee6896875926 100644
--- a/games-engines/openmw/openmw-9999.ebuild
+++ b/games-engines/openmw/openmw-9999.ebuild
@@ -14,30 +14,37 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/OpenMW/openmw.git"
else
SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
S="${WORKDIR}/${PN}-${P}"
+ KEYWORDS="~amd64 ~arm64 ~ppc64"
fi
+# This particular commit is hardcoded in
+# https://gitlab.com/OpenMW/openmw/-/blob/ffe164b28d3a10408e20fdadd2f0168c1e32fd6e/apps/components_tests/CMakeLists.txt#L114-118
MY_TEMPLATE_COMMIT="8966dab24692555eec720c854fb0f73d108070cd"
SRC_URI+="
- test? ( https://gitlab.com/OpenMW/example-suite/-/raw/${MY_TEMPLATE_COMMIT}/data/template.omwgame -> openmw-template-${MY_TEMPLATE_COMMIT}.omwgame )
+ test? (
+ https://gitlab.com/OpenMW/example-suite/-/raw/${MY_TEMPLATE_COMMIT}/game_template/data/template.omwgame
+ -> openmw-template-${MY_TEMPLATE_COMMIT}.omwgame
+ )
"
LICENSE="GPL-3 MIT BitstreamVera ZLIB"
SLOT="0"
-IUSE="doc devtools +osg-fork test +qt5"
+IUSE="doc devtools +gui +osg-fork test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
RESTRICT="!test? ( test )"
-# FIXME: Unbundle dev-games/openscenegraph-qt in extern/osgQt directory,
-# used when BUILD_OPENCS flag is enabled. See bug #676266.
+# TODO: Unbundle dev-games/openscenegraph-qt in extern/osgQt directory,
+# used when BUILD_OPENCS flag is enabled.
+# OpenMW has custom changes to this library.
+# See bug #676266.
RDEPEND="${LUA_DEPS}
app-arch/lz4:=
- >=dev-games/mygui-3.4.3:=
dev-cpp/yaml-cpp:=
dev-db/sqlite:3
dev-games/recastnavigation:=
+ >=dev-games/mygui-3.4.3:=
dev-libs/boost:=[zlib]
dev-libs/icu:=
dev-libs/tinyxml[stl]
@@ -45,16 +52,14 @@ RDEPEND="${LUA_DEPS}
media-libs/openal
media-video/ffmpeg:=
>=sci-physics/bullet-2.86:=[double-precision]
+ sys-libs/zlib
virtual/opengl
osg-fork? ( >=dev-games/openscenegraph-openmw-3.6:=[collada(-),jpeg,png,sdl,svg,truetype,zlib] )
- !osg-fork? ( >=dev-games/openscenegraph-3.5.5:=[collada(-),jpeg,png,sdl,svg,truetype,zlib] )
- qt5? (
+ !osg-fork? ( >=dev-games/openscenegraph-3.6.5:=[collada(-),jpeg,png,sdl,svg,truetype,zlib] )
+ gui? (
app-arch/unshield
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtwidgets:5
+ dev-qt/qtbase:6[gui,network,opengl,widgets]
+ dev-qt/qtsvg:6
)
"
@@ -68,6 +73,9 @@ BDEPEND="
app-text/doxygen[dot]
dev-python/sphinx
)
+ gui? (
+ dev-qt/qttools:6[linguist]
+ )
test? (
dev-cpp/gtest
)
@@ -78,27 +86,34 @@ src_prepare() {
# Use the system tinyxml headers
rm -v extern/oics/tiny{str,xml}* || die
- rm -rv extern/sol3 || die
+
+ # Use the system sol2 (v3) headers
+ rm -r extern/sol3 || die
}
src_configure() {
- use devtools && ! use qt5 &&
- elog "'qt5' USE flag is disabled, 'openmw-cs' will not be installed"
+ use devtools && ! use gui &&
+ elog "'gui' USE flag is disabled, 'openmw-cs' will not be installed"
local mycmakeargs=(
-DBUILD_BSATOOL=$(usex devtools)
-DBUILD_DOCS=$(usex doc)
-DBUILD_ESMTOOL=$(usex devtools)
- -DBUILD_LAUNCHER=$(usex qt5)
+ -DBUILD_LAUNCHER=$(usex gui)
+ -DBUILD_OPENCS=$(usex devtools $(usex gui))
+ -DBUILD_WIZARD=$(usex gui)
-DBUILD_NIFTEST=$(usex devtools)
- -DBUILD_OPENCS=$(usex devtools $(usex qt5))
- -DBUILD_WIZARD=$(usex qt5)
- -DBUILD_UNITTESTS=$(usex test)
+ -DBUILD_COMPONENTS_TESTS=$(usex test)
+ -DBUILD_OPENMW_TESTS=$(usex test)
+ -DBUILD_OPENCS_TESTS=$(usex test $(usex devtools))
+
-DGLOBAL_DATA_PATH="${EPREFIX}/usr/share"
-DICONDIR="${EPREFIX}/usr/share/icons/hicolor/256x256/apps"
-DUSE_SYSTEM_TINYXML=ON
-DOPENMW_USE_SYSTEM_GOOGLETEST=ON
-DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON
+
+ -DQT_DIR="${ESYSROOT}/usr/lib64/cmake/Qt6"
)
if [[ ${ELUA} == luajit ]]; then
@@ -116,9 +131,9 @@ src_configure() {
fi
if use test ; then
- mkdir -p "${BUILD_DIR}"/apps/openmw_test_suite/data || die
+ mkdir -p "${BUILD_DIR}"/apps/components_tests/data || die
cp "${DISTDIR}"/openmw-template-${MY_TEMPLATE_COMMIT}.omwgame \
- "${BUILD_DIR}"/apps/openmw_test_suite/data/template.omwgame || die
+ "${BUILD_DIR}"/apps/components_tests/data/template.omwgame || die
fi
cmake_src_configure
@@ -142,8 +157,13 @@ src_test() {
elog "Skipping tests on ${ELUA}"
return
fi
+
pushd "${BUILD_DIR}" > /dev/null || die
- ./openmw_test_suite || die
+ ./components-tests || die
+ ./openmw-tests || die
+ if use gui && use devtools; then
+ ./openmw-cs-tests || die
+ fi
popd > /dev/null || die
}
@@ -157,9 +177,9 @@ src_install() {
(either by using the launcher or by calling 'openmw-wizard'
directly).\n"
- if ! use qt5; then
+ if ! use gui ; then
DOC_CONTENTS+="\n\n
- USE flag 'qt5' is disabled, 'openmw-launcher' and
+ USE flag 'gui' is disabled, 'openmw-launcher' and
'openmw-wizard' are not available. You are on your own for
making the Morrowind data files available and pointing
openmw at them.\n\n