summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/files/scummvm-tools-2.2.0-strings.patch17
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild13
2 files changed, 22 insertions, 8 deletions
diff --git a/games-engines/scummvm-tools/files/scummvm-tools-2.2.0-strings.patch b/games-engines/scummvm-tools/files/scummvm-tools-2.2.0-strings.patch
new file mode 100644
index 000000000000..1bd3f9f399dc
--- /dev/null
+++ b/games-engines/scummvm-tools/files/scummvm-tools-2.2.0-strings.patch
@@ -0,0 +1,17 @@
+Fix build without native symlinks
+https://bugs.gentoo.org/744424
+
+--- a/configure
++++ b/configure
+@@ -1026,9 +1026,9 @@ void _ebcdic() { char* s = (char*) ebcdi
+ int main() { _ascii (); _ebcdic (); return 0; }
+ EOF
+ $CXX $CXXFLAGS -c -o $TMPO.o tmp_endianness_check.cpp
+-if strings $TMPO.o | grep BIGenDianSyS >/dev/null; then
++if ${STRINGS} $TMPO.o | grep BIGenDianSyS >/dev/null; then
+ _endian=big
+-elif strings $TMPO.o | grep LiTTleEnDian >/dev/null; then
++elif ${STRINGS} $TMPO.o | grep LiTTleEnDian >/dev/null; then
+ _endian=little
+ fi
+ echo $_endian;
diff --git a/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
index c514a09b8b71..3af45ddd2fa7 100644
--- a/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
+++ b/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
WX_GTK_VER=3.0-gtk3
inherit wxwidgets toolchain-funcs
@@ -17,7 +17,7 @@ IUSE="flac iconv mad png vorbis"
RESTRICT="test" # some tests require external files
RDEPEND="
- >=dev-libs/boost-1.32:=
+ dev-libs/boost:=
sys-libs/zlib
x11-libs/wxGTK:${WX_GTK_VER}
flac? ( media-libs/flac )
@@ -35,17 +35,18 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.8.0-binprefix.patch"
+ "${FILESDIR}/${PN}-2.2.0-strings.patch"
)
src_prepare() {
default
- rm -rf *.bat dists/win32 || die
- sed -ri -e '/^(CC|CXX)\b/d' Makefile || die
+ rm -r *.bat dists/win32 || die
}
src_configure() {
setup-wxwidgets
+ tc-export CXX STRINGS
# Not an autoconf script
./configure \
@@ -61,10 +62,6 @@ src_configure() {
$(use_enable vorbis) || die
}
-src_compile() {
- emake STRINGS="$(tc-getSTRINGS)"
-}
-
src_install() {
EXEPREFIX="${PN}-" default
}