summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/rott/rott-1.1.2-r1.ebuild')
-rw-r--r--games-fps/rott/rott-1.1.2-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-fps/rott/rott-1.1.2-r1.ebuild b/games-fps/rott/rott-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..d14d5f9918fe
--- /dev/null
+++ b/games-fps/rott/rott-1.1.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Rise of the Triad for Linux!"
+HOMEPAGE="http://www.icculus.org/rott/"
+SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="demo"
+
+RDEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}/rott
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC =/d' \
+ Makefile || die "sed failed"
+ emake clean
+}
+
+src_compile() {
+ emake -j1 \
+ EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"/usr/share/${PN}/\\\"" \
+ SHAREWARE=$(usex demo "1" "0")
+}
+
+src_install() {
+ dobin rott
+ dodoc ../doc/*.txt ../README
+ doman ../doc/rott.6
+ if use demo ; then
+ cd "${WORKDIR}" || die
+ insinto /usr/share/${PN}
+ doins *.dmo huntbgin.* remote1.rts
+ fi
+}
+
+pkg_postinst() {
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to /usr/share/${PN}/"
+ fi
+}