summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids/memonix')
-rw-r--r--games-kids/memonix/Manifest1
-rw-r--r--games-kids/memonix/memonix-1.6.ebuild48
-rw-r--r--games-kids/memonix/metadata.xml5
3 files changed, 54 insertions, 0 deletions
diff --git a/games-kids/memonix/Manifest b/games-kids/memonix/Manifest
new file mode 100644
index 000000000000..f6949a3161fe
--- /dev/null
+++ b/games-kids/memonix/Manifest
@@ -0,0 +1 @@
+DIST memonix_1.6_src.tar.bz2 6949315 SHA256 c5bd236c5cff2ffc07d98aff698368f32149c2428229fcde913e93bced250eab SHA512 212def9c30cd878103d4ac8b7f57c5fcaeffa74ee7ece18a993c69304de94a2ce9eea24a70af394477532ac9a0887b595e220e106239cac5e6aec5a75d1a8ff1 WHIRLPOOL 723a624ef298b0863d76fe0d53545e11b88ef9020ea3d7168c2b9673f39f1779e390f8f6ab9d3b2a0ac4123ce72e92e1ccb6b814d7f5b98347bb5af84fa1d919
diff --git a/games-kids/memonix/memonix-1.6.ebuild b/games-kids/memonix/memonix-1.6.ebuild
new file mode 100644
index 000000000000..f7804cbbd570
--- /dev/null
+++ b/games-kids/memonix/memonix-1.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils games
+
+DESCRIPTION="Brain teasers, puzzle and memory games for kid's in one pack"
+HOMEPAGE="http://www.viewizard.com/memonix/"
+SRC_URI="http://www.viewizard.com/download/${PN}_${PV}_src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0[sound,opengl,video]
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[vorbis]
+ !games-kids/memonix-bin"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/MemonixSourceCode
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)"
+ doexe ../${P}_build/Memonix
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ../gamedata.vfs
+
+ games_make_wrapper ${PN} "$(games_get_libdir)"/Memonix "${GAMES_DATADIR}"/${PN}
+
+ newicon ../icon48.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ dodoc ReadMe.txt
+
+ prepgamesdirs
+}
diff --git a/games-kids/memonix/metadata.xml b/games-kids/memonix/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-kids/memonix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>