summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/opengfx/opengfx-0.5.3.ebuild')
-rw-r--r--games-misc/opengfx/opengfx-0.5.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-misc/opengfx/opengfx-0.5.3.ebuild b/games-misc/opengfx/opengfx-0.5.3.ebuild
new file mode 100644
index 000000000000..49a98254840f
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.4.0
+ games-util/grfcodec"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ GIMP= emake help # print out the env to make bug reports better
+ GIMP= _V= emake bundle_tar
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}