summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/mudix/files/mudix-4.3-as-needed.patch4
-rw-r--r--games-mud/mudix/mudix-4.3-r2.ebuild30
2 files changed, 32 insertions, 2 deletions
diff --git a/games-mud/mudix/files/mudix-4.3-as-needed.patch b/games-mud/mudix/files/mudix-4.3-as-needed.patch
index 51f5cc4d74fa..4230ac507763 100644
--- a/games-mud/mudix/files/mudix-4.3-as-needed.patch
+++ b/games-mud/mudix/files/mudix-4.3-as-needed.patch
@@ -1,5 +1,5 @@
---- src/Makefile.in.old 2009-02-08 17:32:15.000000000 +0100
-+++ src/Makefile.in 2009-02-08 17:34:15.000000000 +0100
+--- a/src/Makefile.in 2009-02-08 17:32:15.000000000 +0100
++++ b/src/Makefile.in 2009-02-08 17:34:15.000000000 +0100
@@ -23,7 +23,7 @@
$(EXEC): $(O_FILES)
diff --git a/games-mud/mudix/mudix-4.3-r2.ebuild b/games-mud/mudix/mudix-4.3-r2.ebuild
new file mode 100644
index 000000000000..435466c4ef18
--- /dev/null
+++ b/games-mud/mudix/mudix-4.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A small, stable MUD client for the console"
+HOMEPAGE="http://dw.nl.eu.org/mudix.html"
+SRC_URI="http://dw.nl.eu.org/mudix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+)
+
+src_compile() {
+ emake -C src O_FLAGS="${CFLAGS}"
+}
+
+src_install () {
+ dobin mudix
+ dodoc README sample.usr
+}