summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/colorcode/colorcode-0.7.2.ebuild')
-rw-r--r--games-puzzle/colorcode/colorcode-0.7.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-puzzle/colorcode/colorcode-0.7.2.ebuild b/games-puzzle/colorcode/colorcode-0.7.2.ebuild
new file mode 100644
index 000000000000..d1b45241cfe9
--- /dev/null
+++ b/games-puzzle/colorcode/colorcode-0.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2 games
+
+MY_PN=ColorCode
+DESCRIPTION="A free advanced MasterMind clone"
+HOMEPAGE="http://colorcode.laebisch.com/"
+SRC_URI="http://${PN}.laebisch.com/download/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -i -e '/FLAGS/d' ${PN}.pro || die
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ qt4-r2_src_configure
+}
+
+src_install() {
+ dogamesbin ${PN}
+ newicon img/cc64.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}