summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/construo/construo-0.2.2.ebuild')
-rw-r--r--games-puzzle/construo/construo-0.2.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/games-puzzle/construo/construo-0.2.2.ebuild b/games-puzzle/construo/construo-0.2.2.ebuild
index 07653eb74bbf..0f8df9f839a0 100644
--- a/games-puzzle/construo/construo-0.2.2.ebuild
+++ b/games-puzzle/construo/construo-0.2.2.ebuild
@@ -22,8 +22,10 @@ DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch \
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-lGLU.patch
+ sed -i -e 's/^bindir=.*/bindir=@bindir@/' Makefile.am || die
eautoreconf
}
@@ -32,9 +34,6 @@ src_configure() {
}
src_install() {
- emake \
- DESTDIR="${D}" \
- bindir="${GAMES_BINDIR}" install
- dodoc AUTHORS NEWS README TODO
+ default
prepgamesdirs
}