summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/cuyo')
-rw-r--r--games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild46
-rw-r--r--games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild30
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch11
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch30
-rw-r--r--games-puzzle/cuyo/metadata.xml13
5 files changed, 35 insertions, 95 deletions
diff --git a/games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild b/games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild
deleted file mode 100644
index c614a3ea2aa4..000000000000
--- a/games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools gnome2-utils versionator
-
-MY_P="${PN}-$(get_version_component_range 1).~-$(get_version_component_range 2-3)"
-DESCRIPTION="highly addictive and remotely related to tetris"
-HOMEPAGE="https://www.karimmi.de/cuyo/"
-SRC_URI="https://savannah.nongnu.org/download/cuyo/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+music"
-
-DEPEND="sys-libs/zlib
- media-libs/libsdl[sound,video]
- media-libs/sdl-mixer
- music? ( media-libs/sdl-mixer[mod] )
- media-libs/sdl-image
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- eapply \
- "${FILESDIR}"/${P}-gcc44.patch \
- "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-gcc6.patch
- eautoreconf
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild b/games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild
new file mode 100644
index 000000000000..1b3790d034ef
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+# This version (2.~-1.1) should've been 2_pre11 or so, i.e. >=2.0.0 is newer.
+# Optimally need upstream to release >=2.1.2, or will need own custom version.
+MY_P="${PN}-$(ver_cut 1).~-$(ver_cut 2-3)"
+
+DESCRIPTION="Highly addictive and remotely related to tetris"
+HOMEPAGE="https://www.karimmi.de/cuyo/"
+SRC_URI="https://savannah.nongnu.org/download/cuyo/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer[mod]
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc6.patch
+)
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
deleted file mode 100644
index 9ad50b067fb5..000000000000
--- a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cuyo-2.~-1.1.orig/src/stringzeug.h
-+++ cuyo-2.~-1.1/src/stringzeug.h
-@@ -20,7 +20,7 @@
-
- #include <config.h>
- #include <string>
--
-+#include <stdio.h>
-
-
-
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
deleted file mode 100644
index 78bafe2ded47..000000000000
--- a/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- cuyo-2.~-1.1.orig/icons/Makefile.am
-+++ cuyo-2.~-1.1/icons/Makefile.am
-@@ -1,4 +1,4 @@
--desktopdir = $(datadir)/applications
-+desktopdir = /usr/share/applications
- desktop_DATA = cuyo.desktop
-
-
-@@ -25,7 +25,7 @@
- # Das vorige war falsch: die png sollen alle cuyo.png heissen
- # und nicht cuyo-xxxx.png. Deshalb nachfolgend neue Version:
-
--iconsdir = $(datadir)/icons/hicolor
-+iconsdir = /usr/share/icons/hicolor
- icons_DATA = cuyo-32x32.png cuyo-64x64.png
-
- install-iconsDATA:
---- cuyo-2.~-1.1.orig/icons/cuyo.desktop
-+++ cuyo-2.~-1.1/icons/cuyo.desktop
-@@ -3,9 +3,8 @@
- Icon=cuyo
- Type=Application
- Terminal=false
--MimeType=application/x-executable
-+MimeType=application/x-executable;
- Categories=Game;BlocksGame;
--Encoding=UTF-8
- Comment=A tetris like game with many levels
- Comment[de]=Ein Tetris-artiges Spiel mit vielen Leveln
- Exec=cuyo
diff --git a/games-puzzle/cuyo/metadata.xml b/games-puzzle/cuyo/metadata.xml
index 1329ada5712f..7c730d47817a 100644
--- a/games-puzzle/cuyo/metadata.xml
+++ b/games-puzzle/cuyo/metadata.xml
@@ -1,11 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
-<use>
- <flag name="music">Enable playing of background music</flag>
-</use>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
</pkgmetadata>