summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild84
-rw-r--r--games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild55
-rw-r--r--games-puzzle/braid-gog/metadata.xml3
-rw-r--r--games-puzzle/braid-hb/braid-hb-20150611-r1.ebuild84
-rw-r--r--games-puzzle/braid-hb/braid-hb-20150611.ebuild55
-rw-r--r--games-puzzle/braid-hb/metadata.xml3
-rw-r--r--games-puzzle/gnome-sudoku/Manifest3
-rw-r--r--games-puzzle/gnome-sudoku/gnome-sudoku-45.5.ebuild49
-rw-r--r--games-puzzle/gnome-sudoku/gnome-sudoku-46.4.ebuild2
-rw-r--r--games-puzzle/gnome-sudoku/gnome-sudoku-47.1.1.ebuild (renamed from games-puzzle/gnome-sudoku/gnome-sudoku-46.3.ebuild)10
-rw-r--r--games-puzzle/lightsoff/lightsoff-46.0.ebuild2
-rw-r--r--games-puzzle/skladnik/Manifest2
-rw-r--r--games-puzzle/skladnik/skladnik-24.12.2.ebuild (renamed from games-puzzle/skladnik/skladnik-24.12.0.ebuild)6
-rw-r--r--games-puzzle/swell-foop/swell-foop-46.0.ebuild2
14 files changed, 187 insertions, 173 deletions
diff --git a/games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild b/games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild
new file mode 100644
index 000000000000..29f625d647fb
--- /dev/null
+++ b/games-puzzle/braid-gog/braid-gog-2.0.0.3-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_PN="braid"
+DESCRIPTION="Platform game where you manipulate flow of time"
+HOMEPAGE="https://www.gog.com/en/game/braid"
+SRC_URI="gog_${MY_PN}_${PV}.sh"
+S="${WORKDIR}/data/noarch/game"
+
+LICENSE="GOG-EULA Arphic CC-BY-NC-SA-1.0"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="launcher"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ !${CATEGORY}/${MY_PN}-hb
+ media-gfx/nvidia-cg-toolkit[abi_x86_32]
+ media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ launcher? (
+ media-libs/fontconfig:1.0[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXcursor[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]
+ x11-libs/libXfixes[abi_x86_32]
+ x11-libs/libXft[abi_x86_32]
+ x11-libs/libXinerama[abi_x86_32]
+ )
+"
+
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ insinto "${DIR}"
+
+ doexe Braid.bin.x86
+ doins -r data Icon.bmp
+ dodoc READ_ME.txt
+
+ if use launcher; then
+ doexe launcher.bin.x86
+ exeinto "${DIR}"/lib
+ doexe lib/libfltk.so.1.3
+ dosym "../..${DIR}/launcher.bin.x86" /usr/bin/${MY_PN}
+ else
+ dosym "../..${DIR}/Braid.bin.x86" /usr/bin/${MY_PN}
+ fi
+
+ newicon -s 256 Icon.png ${MY_PN}.png
+ make_desktop_entry ${MY_PN} Braid
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use launcher; then
+ elog "You have disabled the launcher. The game will run fullscreen with"
+ elog "Vsync and postprocessing enabled at an optimal framerate by default."
+ elog "Pass these options to change that:"
+ elog ""
+ elog " -windowed -width [X] -height [Y] -no_vsync -no_post -[R]fps"
+ fi
+}
diff --git a/games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild b/games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild
deleted file mode 100644
index 487d6adc7a25..000000000000
--- a/games-puzzle/braid-gog/braid-gog-2.0.0.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop unpacker wrapper xdg
-
-MY_PN="braid"
-DESCRIPTION="Platform game where you manipulate flow of time"
-HOMEPAGE="https://www.gog.com/en/game/braid"
-SRC_URI="gog_${MY_PN}_${PV}.sh"
-
-LICENSE="GOG-EULA Arphic CC-BY-NC-SA-1.0"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-RESTRICT="bindist fetch splitdebug"
-
-BDEPEND="
- app-arch/unzip
-"
-
-RDEPEND="
- media-gfx/nvidia-cg-toolkit[abi_x86_32]
- media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
- virtual/opengl[abi_x86_32]
- x11-libs/fltk:1[abi_x86_32]
- x11-libs/libX11[abi_x86_32]
- !${CATEGORY}/${MY_PN}-hb
-"
-
-S="${WORKDIR}/data/noarch/game"
-DIR="/opt/${MY_PN}"
-QA_PREBUILT="${DIR#/}/*"
-
-pkg_nofetch() {
- einfo "Please buy and download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "and move it to your distfiles directory."
-}
-
-src_unpack() {
- unpack_zip ${A}
-}
-
-src_install() {
- exeinto "${DIR}"
- insinto "${DIR}"
-
- doexe {Braid,launcher}.bin.x86
- doins -r data Icon.*
- dodoc READ_ME.txt
-
- make_wrapper ${MY_PN} ./launcher.bin.x86 "${DIR}" /usr/$(ABI=x86 get_libdir)/fltk
- make_desktop_entry ${MY_PN} Braid "${EPREFIX}${DIR}"/Icon.png
-}
diff --git a/games-puzzle/braid-gog/metadata.xml b/games-puzzle/braid-gog/metadata.xml
index 7c730d47817a..9628757c45f0 100644
--- a/games-puzzle/braid-gog/metadata.xml
+++ b/games-puzzle/braid-gog/metadata.xml
@@ -5,4 +5,7 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="launcher">Install FLTK-based launcher that you probably don't need</flag>
+ </use>
</pkgmetadata>
diff --git a/games-puzzle/braid-hb/braid-hb-20150611-r1.ebuild b/games-puzzle/braid-hb/braid-hb-20150611-r1.ebuild
new file mode 100644
index 000000000000..fbcfe6c7f880
--- /dev/null
+++ b/games-puzzle/braid-hb/braid-hb-20150611-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_PN="braid"
+DESCRIPTION="Platform game where you manipulate flow of time"
+HOMEPAGE="https://www.humblebundle.com/store/braid"
+SRC_URI="BraidSetup-${PV:0:4}-${PV:4:2}-${PV:6:2}.sh"
+S="${WORKDIR}/data"
+
+LICENSE="all-rights-reserved Arphic CC-BY-NC-SA-1.0"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="launcher"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ !${CATEGORY}/${MY_PN}-gog
+ media-gfx/nvidia-cg-toolkit[abi_x86_32]
+ media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ launcher? (
+ media-libs/fontconfig:1.0[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXcursor[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]
+ x11-libs/libXfixes[abi_x86_32]
+ x11-libs/libXft[abi_x86_32]
+ x11-libs/libXinerama[abi_x86_32]
+ )
+"
+
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ insinto "${DIR}"
+
+ doexe x86/Braid.bin.x86
+ doins -r noarch/{data,Icon.bmp}
+ dodoc noarch/READ_ME.txt
+
+ if use launcher; then
+ doexe x86/launcher.bin.x86
+ exeinto "${DIR}"/lib
+ doexe x86/lib/libfltk.so.1.3
+ dosym "../..${DIR}/launcher.bin.x86" /usr/bin/${MY_PN}
+ else
+ dosym "../..${DIR}/Braid.bin.x86" /usr/bin/${MY_PN}
+ fi
+
+ newicon -s 256 noarch/Icon.png ${MY_PN}.png
+ make_desktop_entry ${MY_PN} Braid
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use launcher; then
+ elog "You have disabled the launcher. The game will run fullscreen with"
+ elog "Vsync and postprocessing enabled at an optimal framerate by default."
+ elog "Pass these options to change that:"
+ elog ""
+ elog " -windowed -width [X] -height [Y] -no_vsync -no_post -[R]fps"
+ fi
+}
diff --git a/games-puzzle/braid-hb/braid-hb-20150611.ebuild b/games-puzzle/braid-hb/braid-hb-20150611.ebuild
deleted file mode 100644
index e289db38e3e0..000000000000
--- a/games-puzzle/braid-hb/braid-hb-20150611.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop unpacker wrapper xdg
-
-MY_PN="braid"
-DESCRIPTION="Platform game where you manipulate flow of time"
-HOMEPAGE="https://www.humblebundle.com/store/braid"
-SRC_URI="BraidSetup-${PV:0:4}-${PV:4:2}-${PV:6:2}.sh"
-
-LICENSE="all-rights-reserved Arphic CC-BY-NC-SA-1.0"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-RESTRICT="bindist fetch splitdebug"
-
-BDEPEND="
- app-arch/unzip
-"
-
-RDEPEND="
- media-gfx/nvidia-cg-toolkit[abi_x86_32]
- media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
- virtual/opengl[abi_x86_32]
- x11-libs/fltk:1[abi_x86_32]
- x11-libs/libX11[abi_x86_32]
- !${CATEGORY}/${MY_PN}-gog
-"
-
-S="${WORKDIR}/data"
-DIR="/opt/${MY_PN}"
-QA_PREBUILT="${DIR#/}/*"
-
-pkg_nofetch() {
- einfo "Please buy and download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "and move it to your distfiles directory."
-}
-
-src_unpack() {
- unpack_zip ${A}
-}
-
-src_install() {
- exeinto "${DIR}"
- insinto "${DIR}"
-
- doexe x86/{Braid,launcher}.bin.x86
- doins -r noarch/{data,Icon.*}
- dodoc noarch/READ_ME.txt
-
- make_wrapper ${MY_PN} ./launcher.bin.x86 "${DIR}" /usr/$(ABI=x86 get_libdir)/fltk
- make_desktop_entry ${MY_PN} Braid "${EPREFIX}${DIR}"/Icon.png
-}
diff --git a/games-puzzle/braid-hb/metadata.xml b/games-puzzle/braid-hb/metadata.xml
index 7c730d47817a..9628757c45f0 100644
--- a/games-puzzle/braid-hb/metadata.xml
+++ b/games-puzzle/braid-hb/metadata.xml
@@ -5,4 +5,7 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="launcher">Install FLTK-based launcher that you probably don't need</flag>
+ </use>
</pkgmetadata>
diff --git a/games-puzzle/gnome-sudoku/Manifest b/games-puzzle/gnome-sudoku/Manifest
index ab9b022374bb..dbfaa77dc0be 100644
--- a/games-puzzle/gnome-sudoku/Manifest
+++ b/games-puzzle/gnome-sudoku/Manifest
@@ -1,3 +1,2 @@
-DIST gnome-sudoku-45.5.tar.xz 395164 BLAKE2B 4c310a769d2ebdac1bb811d39f0cef8aad9cc424c39b7f84d64e4954c967e4d8ad7de59bbd92f84080dd75e0cbd104d71e0201b8be54611c29dd8c5cccc2ad18 SHA512 13d47ee3f85f3a481721cee98bcf7c552d3b5110544b5ba52b0e0014f55199e4840745c925eb4848f7609d3f9e6379c31138ac08894e8394c31ace722b8a796d
-DIST gnome-sudoku-46.3.tar.xz 396856 BLAKE2B ec2f0e11837dbba26b0ea5d31dd0c404d1193c43aa272d67f0e67bad4037e8d0544b89061c28ad356ddb4afeb80bfa39aaef02733cfde087643a88083b9c1489 SHA512 3a1e5607dcbc2841d9c0506da221affc2e8a64b2c96f5cf6744747be07445f6418ca853ae324caec3265882ba65f66b8dd5b06c185d334b47c64d7be65a41ac3
DIST gnome-sudoku-46.4.tar.xz 396828 BLAKE2B ae2a7369f01af054458e34b2023a3d736f7940de5c7aac924f87acceaf46faec57b84908754b49cd79082754492d6bf8bc27cae17fdce60d95470eb24d069260 SHA512 439752b6d963f5ae19ce15914d21159ff051c6fddea1590767f8661d40dc7ad4b4ddee730f3a2f76f6651b12b946043708c648e6d3a367788be8ce7e507b939a
+DIST gnome-sudoku-47.1.1.tar.xz 420024 BLAKE2B 0d55bce403da7b9e813b01c955d69e54412afc7c183f5801a1fe45ac13e2a0009f7451824558582902507c47016f6335d00a18efc3d8767f9840540f47d19f0b SHA512 864d6838f0842c9be946ec6ed43d0c76d00c3b579952097f88aaca5d94cff5211c65d8a67c09bdb65cc0ff0f37be304077745afa0db64d299f2f61d0580b46cc
diff --git a/games-puzzle/gnome-sudoku/gnome-sudoku-45.5.ebuild b/games-puzzle/gnome-sudoku/gnome-sudoku-45.5.ebuild
deleted file mode 100644
index 6392ba4c303b..000000000000
--- a/games-puzzle/gnome-sudoku/gnome-sudoku-45.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org gnome2-utils meson vala xdg
-
-DESCRIPTION="Test your logic skills in this number grid puzzle"
-HOMEPAGE="https://wiki.gnome.org/Apps/Sudoku https://gitlab.gnome.org/GNOME/gnome-sudoku"
-
-LICENSE="GPL-3+ CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~riscv x86"
-
-RDEPEND="
- >=dev-libs/glib-2.40:2
- dev-libs/libgee:0.8=[introspection]
- >=gui-libs/gtk-4.10.0[introspection]
- >=gui-libs/libadwaita-1.4_alpha[introspection,vala]
- dev-libs/json-glib
- >=dev-libs/qqwing-1.3.4:=
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/pango[introspection]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- $(vala_depend)
- dev-libs/appstream-glib
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- vala_setup
- xdg_environment_reset
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
diff --git a/games-puzzle/gnome-sudoku/gnome-sudoku-46.4.ebuild b/games-puzzle/gnome-sudoku/gnome-sudoku-46.4.ebuild
index 2026823b5280..28c3ea68ec56 100644
--- a/games-puzzle/gnome-sudoku/gnome-sudoku-46.4.ebuild
+++ b/games-puzzle/gnome-sudoku/gnome-sudoku-46.4.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-sudoku"
LICENSE="GPL-3+ CC-BY-SA-3.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~loong ~riscv x86"
RDEPEND="
>=dev-libs/glib-2.40:2
diff --git a/games-puzzle/gnome-sudoku/gnome-sudoku-46.3.ebuild b/games-puzzle/gnome-sudoku/gnome-sudoku-47.1.1.ebuild
index 16fef17ca527..15ff28650d46 100644
--- a/games-puzzle/gnome-sudoku/gnome-sudoku-46.3.ebuild
+++ b/games-puzzle/gnome-sudoku/gnome-sudoku-47.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,17 +6,17 @@ EAPI=8
inherit gnome.org gnome2-utils meson vala xdg
DESCRIPTION="Test your logic skills in this number grid puzzle"
-HOMEPAGE="https://wiki.gnome.org/Apps/Sudoku https://gitlab.gnome.org/GNOME/gnome-sudoku"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-sudoku"
LICENSE="GPL-3+ CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
RDEPEND="
- >=dev-libs/glib-2.40:2
+ >=dev-libs/glib-2.76:2
dev-libs/libgee:0.8=[introspection]
- >=gui-libs/gtk-4.10.0[introspection]
- >=gui-libs/libadwaita-1.4_alpha[introspection,vala]
+ >=gui-libs/gtk-4.15.2[introspection]
+ >=gui-libs/libadwaita-1.6[introspection,vala]
dev-libs/json-glib
>=dev-libs/qqwing-1.3.4:=
x11-libs/gdk-pixbuf:2[introspection]
diff --git a/games-puzzle/lightsoff/lightsoff-46.0.ebuild b/games-puzzle/lightsoff/lightsoff-46.0.ebuild
index 281b77fcd183..f3a5ceb0f859 100644
--- a/games-puzzle/lightsoff/lightsoff-46.0.ebuild
+++ b/games-puzzle/lightsoff/lightsoff-46.0.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://gitlab.gnome.org/GNOME/lightsoff"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~loong ~riscv x86"
RDEPEND="
>=dev-libs/glib-2.38.0:2
diff --git a/games-puzzle/skladnik/Manifest b/games-puzzle/skladnik/Manifest
index 49ad86898501..9cd55d76f412 100644
--- a/games-puzzle/skladnik/Manifest
+++ b/games-puzzle/skladnik/Manifest
@@ -1,2 +1,2 @@
DIST skladnik-24.08.3.tar.xz 409780 BLAKE2B 6a98d068abcd84f906411b51ae030214df448df3017ae7251d363800f05db243c075be4173e05d841babea659afea3cc8c72e91389be7659a3ed5077549c8d1f SHA512 f06e061576d953e7bdc5bb1eb1eb571452585b76380a4ddde11403b55d81e58e4fb3c7cb464b715e7e0370e13ae96ca00dbb477e58d5493c175843676932e964
-DIST skladnik-24.12.0.tar.xz 413040 BLAKE2B f8d829ebd2615c2089bbe42f9c49db6554fa5bc4f7a7772699309dff694903e1d481130b7c5c37a2d8b1c03e4b467876fc4a3d1e12ca8d51a28617359b12e24c SHA512 a247a176e70218f9e4cc94a854f79cd7a4eb7e4cc4329b19a1f2cbcfd95417c64067d7e3ebb49cb6ef14aee6a4f604274e59a58edfc100399e3635165ad0a3b5
+DIST skladnik-24.12.2.tar.xz 413100 BLAKE2B 699d229feeefa6c7bbc275063083af512b78a7be3f6f26a9485da7d81e2b76ead8180f4526b93d135afe68a4c86f4ef7b8d7054499250faa5f6da2fa4237240b SHA512 ecaafd80304813062b519127809d68607e441455478601483afc9adecfabf0c9d4158d2f58b7c8c566410f17dbc4a95d0a7d61ee9fbe6af0f5eb1a3f6d875c50
diff --git a/games-puzzle/skladnik/skladnik-24.12.0.ebuild b/games-puzzle/skladnik/skladnik-24.12.2.ebuild
index db53201cea58..9149a1216672 100644
--- a/games-puzzle/skladnik/skladnik-24.12.0.ebuild
+++ b/games-puzzle/skladnik/skladnik-24.12.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_HANDBOOK="optional"
PVCUT=$(ver_cut 1-3)
-KFMIN=6.5.0
+KFMIN=6.7.0
QTMIN=6.7.2
inherit ecm gear.kde.org
@@ -14,7 +14,7 @@ HOMEPAGE="https://apps.kde.org/skladnik/ https://invent.kde.org/games/skladnik"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
RDEPEND="
>=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
diff --git a/games-puzzle/swell-foop/swell-foop-46.0.ebuild b/games-puzzle/swell-foop/swell-foop-46.0.ebuild
index aa0d80360354..a72fe0651578 100644
--- a/games-puzzle/swell-foop/swell-foop-46.0.ebuild
+++ b/games-puzzle/swell-foop/swell-foop-46.0.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="https://gitlab.gnome.org/GNOME/swell-foop"
LICENSE="GPL-2+ FDL-1.1+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~loong ~riscv x86"
RDEPEND="
>=dev-libs/glib-2.74:2