summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild b/games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild
index 53b5aa2c7c59..e92811a4437c 100644
--- a/games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild
+++ b/games-puzzle/lmarbles/lmarbles-1.0.8-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="puzzle game inspired by Atomix and written in SDL"
@@ -12,18 +13,17 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="media-libs/libsdl[video]
- media-libs/sdl-mixer"
+DEPEND="
+ acct-group/gamestat
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer
+"
RDEPEND="${DEPEND}"
-src_prepare() {
- default
- mv configure.{in,ac}
- rm *.m4
- eautoreconf
-}
-
src_install() {
default
dodoc src/manual/*
+
+ fperms 660 /var/lib/lmarbles.prfs
+ fowners root:gamestat /var/lib/lmarbles.prfs
}