summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/gnome-taquin/Manifest1
-rw-r--r--games-puzzle/gnome-taquin/gnome-taquin-3.36.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/games-puzzle/gnome-taquin/Manifest b/games-puzzle/gnome-taquin/Manifest
index 45a6f1441023..b19c7ec81d52 100644
--- a/games-puzzle/gnome-taquin/Manifest
+++ b/games-puzzle/gnome-taquin/Manifest
@@ -1 +1,2 @@
DIST gnome-taquin-3.34.4.tar.xz 5242780 BLAKE2B 9763d77f77ddfc0c283663be22258b7baa2529f0d3efc05200f1735ca8766008451e648b6fb7b15e4f06887a6c040b5f25e5e63291b00036180a134854bcc57c SHA512 15da9ebc8c1aa89b350132efe034b977d96a62e686d01cfe8547b47541f1c2d30d564ba3eed35e3c80818835703cf4f33552d373908a2e8287c3982c041d7eef
+DIST gnome-taquin-3.36.4.tar.xz 5253972 BLAKE2B ddeacc57e52e434c5f3f7956226c4dc3c25416c61d8e920116dafebd89a3b442c01c54840bacdb93d5ee6ca4b6428c36f77c56f53651fe90ee8fda9026b23db5 SHA512 72e28698e292ec198c77f4f56624bafd88220157582d220ace363e29bb2f3bdbe7198c30348a6aef12e07dce275be6280fd4dc8a6bcc58f31d1e5ef54d0f3f7d
diff --git a/games-puzzle/gnome-taquin/gnome-taquin-3.36.4.ebuild b/games-puzzle/gnome-taquin/gnome-taquin-3.36.4.ebuild
new file mode 100644
index 000000000000..21f4f4ca3bba
--- /dev/null
+++ b/games-puzzle/gnome-taquin/gnome-taquin-3.36.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Move tiles so that they reach their places"
+HOMEPAGE="https://wiki.gnome.org/Apps/Taquin"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.22.23:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+# libxml2+gdk-pixbuf required for glib-compile-resources (xml-stripblanks and to-pixdata)
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-libs/gdk-pixbuf:2
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}