summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/monopd')
-rw-r--r--games-server/monopd/Manifest2
-rw-r--r--games-server/monopd/files/monopd.in20
-rw-r--r--games-server/monopd/metadata.xml5
-rw-r--r--games-server/monopd/monopd-0.9.7.ebuild39
-rw-r--r--games-server/monopd/monopd-0.9.8.ebuild39
5 files changed, 105 insertions, 0 deletions
diff --git a/games-server/monopd/Manifest b/games-server/monopd/Manifest
new file mode 100644
index 000000000000..397a9c4e29ab
--- /dev/null
+++ b/games-server/monopd/Manifest
@@ -0,0 +1,2 @@
+DIST monopd-0.9.7.tar.gz 180318 SHA256 34aa975c8ee410f661622f91a63c4199e68a333123218b3e48300be1bc7afc30 SHA512 55b2e3b6f16f20fc1928d79eaecbdceaf9b9a8c9fe44b2cf8a8489347c728a006df78043235504e3931bb71b90e7493375fb2b71285447ad4a11dd434aa3133f WHIRLPOOL 14c47c95b64fafe07dc37ea61579ad42cf09c535f35b8f22d7dbdfa1dd04c529173e22c99287d2c748266ab00cdd82e28340d945924681849a1209911d6fcd16
+DIST monopd-0.9.8.tar.gz 180509 SHA256 408321ea73f2e7cdee570973ff50a3ee1a2f7078f8f19e8861614f238574ec9a SHA512 c39806c51f27eb29f154db520bf1c49d10e5a8587b3d23411de43bd07cd3553c398ea31802473d9cdcf350f5432abeb7bde62478e1844abc93d73395951c87b1 WHIRLPOOL 9e18cfac665610f5372af16128b87095eeb19251cd511b489124c4e7d8845bcc123c6a1fc51d8d457cdabf6cacc6dcf704766b8ff1a96c0f5940bd4f66595272
diff --git a/games-server/monopd/files/monopd.in b/games-server/monopd/files/monopd.in
new file mode 100644
index 000000000000..640ab25eb219
--- /dev/null
+++ b/games-server/monopd/files/monopd.in
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting monopd server"
+ start-stop-daemon --start -q -b --exec GENTOO_DIR/monopd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping monopd server"
+ start-stop-daemon --stop -q --exec GENTOO_DIR/monopd
+ eend $?
+}
diff --git a/games-server/monopd/metadata.xml b/games-server/monopd/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-server/monopd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-server/monopd/monopd-0.9.7.ebuild b/games-server/monopd/monopd-0.9.7.ebuild
new file mode 100644
index 000000000000..b65372d86cda
--- /dev/null
+++ b/games-server/monopd/monopd-0.9.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils systemd games
+
+DESCRIPTION="server for atlantik games"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=sys-libs/libmath++-0.0.3"
+
+src_prepare() {
+ sed "s:GENTOO_DIR:\"${GAMES_BINDIR}\":" \
+ "${FILESDIR}"/monopd.in > "${T}"/monopd || die
+ sed -i \
+ -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ doinitd "${T}"/monopd
+ systemd_dounit doc/systemd/monopd.s*
+ prepgamesdirs
+}
diff --git a/games-server/monopd/monopd-0.9.8.ebuild b/games-server/monopd/monopd-0.9.8.ebuild
new file mode 100644
index 000000000000..c84c436780e2
--- /dev/null
+++ b/games-server/monopd/monopd-0.9.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils systemd games
+
+DESCRIPTION="server for atlantik games"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=sys-libs/libmath++-0.0.3"
+
+src_prepare() {
+ sed "s:GENTOO_DIR:\"${GAMES_BINDIR}\":" \
+ "${FILESDIR}"/monopd.in > "${T}"/monopd || die
+ sed -i \
+ -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ doinitd "${T}"/monopd
+ systemd_dounit doc/systemd/monopd.s*
+ prepgamesdirs
+}