summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/crashtest')
-rw-r--r--games-simulation/crashtest/crashtest-1.1-r1.ebuild46
-rw-r--r--games-simulation/crashtest/files/crashtest-1.1-gentoo.patch12
2 files changed, 52 insertions, 6 deletions
diff --git a/games-simulation/crashtest/crashtest-1.1-r1.ebuild b/games-simulation/crashtest/crashtest-1.1-r1.ebuild
new file mode 100644
index 000000000000..6c3b1e2ee848
--- /dev/null
+++ b/games-simulation/crashtest/crashtest-1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="Educational car crash simulator"
+HOMEPAGE="http://www.stolk.org/crashtest/"
+SRC_URI="http://www.stolk.org/crashtest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-games/ode
+ media-libs/alsa-lib
+ media-libs/freeglut
+ x11-libs/fltk:1[opengl]
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ >=media-libs/plib-1.8.4"
+
+S=${WORKDIR}/${P}/src-${PN}
+
+PATCHES=(
+ "${FILESDIR}/${P}"-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ -e "s:@GENTOO_BINDIR@:/usr/bin:" \
+ Makefile ${PN}.cxx || die
+ append-cppflags -DHAVE_ISNANF
+}
+
+src_install() {
+ default
+ make_desktop_entry ${PN} Crashtest
+}
diff --git a/games-simulation/crashtest/files/crashtest-1.1-gentoo.patch b/games-simulation/crashtest/files/crashtest-1.1-gentoo.patch
index 820fd4924737..b384c87278c2 100644
--- a/games-simulation/crashtest/files/crashtest-1.1-gentoo.patch
+++ b/games-simulation/crashtest/files/crashtest-1.1-gentoo.patch
@@ -1,6 +1,6 @@
-diff -ru crashtest-1.1.orig/src-crashtest/Makefile crashtest-1.1/src-crashtest/Makefile
---- crashtest-1.1.orig/src-crashtest/Makefile 2009-02-15 17:11:31.000000000 -0500
-+++ crashtest-1.1/src-crashtest/Makefile 2009-10-14 01:00:13.900627555 -0400
+diff -ru a/Makefile b/Makefile
+--- a/Makefile 2009-02-15 17:11:31.000000000 -0500
++++ b/Makefile 2009-10-14 01:00:13.900627555 -0400
@@ -1,34 +1,12 @@
-# EDIT THESE SETTINGS
-
@@ -69,9 +69,9 @@ diff -ru crashtest-1.1.orig/src-crashtest/Makefile crashtest-1.1/src-crashtest/M
# Models
install -m 644 models/testground.3ds $(GAMEDIR)/models/testground.3ds
install -m 644 models/biped_torso.3ds $(GAMEDIR)/models/biped_torso.3ds
-diff -ru crashtest-1.1.orig/src-crashtest/crashtest.cxx crashtest-1.1/src-crashtest/crashtest.cxx
---- crashtest-1.1.orig/src-crashtest/crashtest.cxx 2009-02-15 17:08:24.000000000 -0500
-+++ crashtest-1.1/src-crashtest/crashtest.cxx 2009-10-14 01:01:25.822753522 -0400
+diff -ru a/crashtest.cxx b/crashtest.cxx
+--- a/crashtest.cxx 2009-02-15 17:08:24.000000000 -0500
++++ b/crashtest.cxx 2009-10-14 01:01:25.822753522 -0400
@@ -615,13 +615,7 @@
int main(int argc, char *argv[])