summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/gracer/gracer-0.1.5-r1.ebuild')
-rw-r--r--games-sports/gracer/gracer-0.1.5-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-sports/gracer/gracer-0.1.5-r1.ebuild b/games-sports/gracer/gracer-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..d841e11071c7
--- /dev/null
+++ b/games-sports/gracer/gracer-0.1.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="3D motor sports simulator"
+HOMEPAGE="http://gracer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gracer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="joystick"
+
+DEPEND="
+ dev-lang/tcl:0
+ media-libs/freeglut
+ media-libs/giflib
+ media-libs/libpng:0
+ media-libs/plib
+ x11-libs/libXi
+ x11-libs/libXmu
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl"
+
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gldefs.patch
+ "${FILESDIR}"/${PN}-gcc-3.4.patch
+ "${FILESDIR}/${P}"-gcc41.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-libpng14.patch
+ "${FILESDIR}"/${P}-png15.patch
+ "${FILESDIR}"/${P}-giflib.patch
+ "${FILESDIR}"/${P}-warnings.patch
+)
+
+src_configure() {
+ econf \
+ --enable-gif \
+ --enable-jpeg \
+ --enable-png \
+ $(use_enable joystick)
+ sed -i \
+ -e 's:-lplibsl:-lplibsl -lplibul:' \
+ $(find -name Makefile) || die
+}