summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/maxr/maxr-0.2.9.ebuild')
-rw-r--r--games-strategy/maxr/maxr-0.2.9.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/games-strategy/maxr/maxr-0.2.9.ebuild b/games-strategy/maxr/maxr-0.2.9.ebuild
index 1835decca361..624345a06b30 100644
--- a/games-strategy/maxr/maxr-0.2.9.ebuild
+++ b/games-strategy/maxr/maxr-0.2.9.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils desktop
+
+inherit cmake-utils desktop gnome2-utils
DESCRIPTION="Mechanized Assault and Exploration Reloaded"
HOMEPAGE="http://www.maxr.org/"
@@ -20,14 +21,19 @@ DEPEND="${RDEPEND}"
src_configure() {
mycmakeargs=(
- -DMAXR_BUILD_DEDICATED_SERVER="$(usex dedicated)"
- "-DCMAKE_BUILD_TYPE=Release")
+ -DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
+ -DCMAKE_BUILD_TYPE=Release
+ )
cmake-utils_src_configure
}
src_install() {
- doicon data/maxr.png
- make_desktop_entry maxr "Mechanized Assault and Exploration Reloaded"
cmake-utils_src_install
+ doicon -s 128 data/${PN}.png
+ make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }