summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/Manifest1
-rw-r--r--games-strategy/freeorion/freeorion-0.4.9_p20200409.ebuild82
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild6
3 files changed, 86 insertions, 3 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index e8a787a99287..5427b843917a 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1,2 +1,3 @@
DIST freeorion-0.4.7.1.tar.gz 105942075 BLAKE2B f75940ac79e329fd7e03e85b1cd712ff6dcf06583ad8feff43f8b2d6e28a53c9029724d1450d26d2367bafd1d04858e3659b8e47986df96657d91526f594eb5e SHA512 9c8d0437ee827a1104a541e1123ce6b5d229bd6253bfe275028805a4c34de882ca3a9d5361e3f64098f935d0926a656a64fe468690c8d195e05de86cd1b2699d
DIST freeorion-0.4.8_p20190501.tar.gz 106506540 BLAKE2B 5442eeeaff486a5525b4282c7ef72001a935c4429fea89a720f94a033a2c29e56855605376efe22d13194ae3f49105fe26f37554d2c8d560bfb76dc69d738128 SHA512 d378c0e9b63118261bf5ac1c99190929ff0cd52b3a270e43fe2be80cc7993457bcc7b70083ff493a6b96b250e1988e40470bef410af5ce3d49644ccf934974d3
+DIST freeorion-0.4.9_p20200409.tar.gz 124663848 BLAKE2B 7468a386829498c9ca971e686bda216002b6f263fbc0f3784e7898854ad91278441579c1a3e0d1ef2d92b46747d14a17463e46d7ba16f06633e9a5d474ce3b9c SHA512 09fe8db818c3f22bac94577461d9ada082a2c8365cb524948bf13650ea368fcc55043f4df2f9701075011c890a08197e7f7bb13d8884cb41cc8e1346b8538345
diff --git a/games-strategy/freeorion/freeorion-0.4.9_p20200409.ebuild b/games-strategy/freeorion/freeorion-0.4.9_p20200409.ebuild
new file mode 100644
index 000000000000..dba94bf60f98
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.9_p20200409.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+inherit cmake-utils python-single-r1 xdg
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="https://www.freeorion.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/freeorion/freeorion.git"
+else
+ KEYWORDS="~amd64"
+ if [[ ${PV} = *_p* ]]; then
+ COMMIT="1570afb475763b13f5d2f434037ec907da812bb4"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ fi
+fi
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
+SLOT="0"
+IUSE="dedicated"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.67:=[python,threads,${PYTHON_MULTI_USEDEP}]
+ ')
+ !dedicated? (
+ media-libs/freealut
+ >=media-libs/freetype-2.5.5
+ media-libs/glew:=
+ >=media-libs/libogg-1.1.3
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,opengl,video]
+ >=media-libs/libvorbis-1.1.2
+ media-libs/openal
+ sci-physics/bullet
+ virtual/opengl
+ )
+ sys-libs/zlib
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # build system is using FindPythonLibs.cmake which needs python:2
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -e "s/-O3//" -i CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_HEADLESS="$(usex dedicated)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newenvd "${FILESDIR}/${PN}.envd" 99${PN}
+}
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 5bf1f6f4f99a..dba94bf60f98 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
inherit cmake-utils python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
else
KEYWORDS="~amd64"
if [[ ${PV} = *_p* ]]; then
- COMMIT="2a49c05796f1c92b96ce9b2aeaf0124fc8be7a77"
+ COMMIT="1570afb475763b13f5d2f434037ec907da812bb4"
SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
else
@@ -35,7 +35,7 @@ BDEPEND="
"
RDEPEND="
$(python_gen_cond_dep '
- >=dev-libs/boost-1.58:=[python,threads,${PYTHON_MULTI_USEDEP}]
+ >=dev-libs/boost-1.67:=[python,threads,${PYTHON_MULTI_USEDEP}]
')
!dedicated? (
media-libs/freealut