summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/joystick/files/joystick-1.6.0-build.patch')
-rw-r--r--games-util/joystick/files/joystick-1.6.0-build.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-util/joystick/files/joystick-1.6.0-build.patch b/games-util/joystick/files/joystick-1.6.0-build.patch
new file mode 100644
index 000000000000..fa60ec719917
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.6.0-build.patch
@@ -0,0 +1,34 @@
+--- linuxconsoletools-1.6.0/docs/Makefile
++++ linuxconsoletools-1.6.0/docs/Makefile
+@@ -20,9 +20,13 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1 evdev-joystick.1
+
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
++
+ PREFIX ?= /usr/local
+
+ install:
+--- linuxconsoletools-1.6.0/utils/Makefile
++++ linuxconsoletools-1.6.0/utils/Makefile
+@@ -27,9 +27,13 @@
+
+ CFLAGS ?= -g -O2 -Wall
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store evdev-joystick
+
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
++
+ PREFIX ?= /usr/local
+
+ compile: $(PROGRAMS)