summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/sc-controller')
-rw-r--r--games-util/sc-controller/Manifest1
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index b712ecee7617..9b7064f7ec97 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1 +1,2 @@
DIST sc-controller-0.4.8.2.tar.gz 2520528 BLAKE2B 0c98e1fd49e846909ec0a78c5bbf48731de464ab79ebe3e1b0370e2a6f176e925e6f2b288c17358221b2e50be0cd783f31f05324ac585aec310967d148ce5011 SHA512 8d157e871fa519ebd3eee27dd1c0ff1afe6f79201df12578aa31f3cbc62974bd7ba47c8a097870b693a7abaacaadd1e502012c9664c0aecddbd982fa10c7f84d
+DIST sc-controller-0.4.8.6.tar.gz 2524756 BLAKE2B b31454fde0705bd49cdf3d56aec43d230617877a1dd1f72bef84d772c28f153b2e6812fd50b096e32a2ea3be549cfd1ee5fb3f9cf138c1dbc73c004ec11984b7 SHA512 d6f8098bff0fce064e194815a6c9bbf6ee974e22af056df9a12ebc24de4f1a22decfcf5191565c81aed39e3aa73b742bdc26040945e2b87543b67202834b46ea
diff --git a/games-util/sc-controller/sc-controller-0.4.8.6.ebuild b/games-util/sc-controller/sc-controller-0.4.8.6.ebuild
new file mode 100644
index 000000000000..764a714fde01
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 linux-info xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
+SRC_URI="https://github.com/Ryochan7/sc-controller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 CC0-1.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]')
+ gnome-base/librsvg[introspection]
+ x11-libs/gtk+:3[introspection]
+ udev? ( games-util/game-device-udev-rules )"
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ local CONFIG_CHECK="~INPUT_UINPUT"
+
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}