summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/wit/files/wit-3.02a-makefile.patch')
-rw-r--r--games-util/wit/files/wit-3.02a-makefile.patch113
1 files changed, 102 insertions, 11 deletions
diff --git a/games-util/wit/files/wit-3.02a-makefile.patch b/games-util/wit/files/wit-3.02a-makefile.patch
index a0dea1405a6e..a0172d50f0f7 100644
--- a/games-util/wit/files/wit-3.02a-makefile.patch
+++ b/games-util/wit/files/wit-3.02a-makefile.patch
@@ -1,9 +1,21 @@
Don't link libdl into wfuse as it's unnecessary, use system bzip2, respect user
CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
---- wiimms-iso-tools.source-3.02a/Makefile
-+++ wiimms-iso-tools.source-3.02a/Makefile
-@@ -171,7 +171,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -111,11 +111,6 @@
+ #-------------------------------------------------------------------------------
+ # compiler settings
+
+-PRE ?=
+-CC = $(PRE)gcc
+-CPP = $(PRE)g++
+-STRIP = $(PRE)strip
+-
+ #-------------------------------------------------------------------------------
+ # files
+
+@@ -171,7 +166,7 @@
TOPT_wit := $(OPT_STATIC)
TOPT_wwt := $(OPT_STATIC)
TOPT_wdf := $(OPT_STATIC)
@@ -12,7 +24,7 @@ CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
#TOPT_ALL := $(TOPT_wit) $(TOPT_wwt) $(TOPT_wdf) $(TOPT_wfuse)
-@@ -206,8 +206,8 @@
+@@ -206,8 +201,8 @@
endif
# lib summary
@@ -23,11 +35,12 @@ CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
RM_FILES += $(foreach l,$(LIB_LIST),src/$(l)/*.{d,o})
-@@ -297,10 +297,8 @@
+@@ -297,10 +292,9 @@
DEFINES1 += -D_LZMA_PROB32=1 # LZMA option
DEFINES = $(strip $(DEFINES1) $(MODE) $(XDEF))
-CFLAGS += -fomit-frame-pointer -fno-strict-aliasing -funroll-loops
++CFLAGS += -fno-strict-aliasing
CFLAGS += -Wall -Wno-parentheses -Wno-unused-function
-#CFLAGS += -O3 -Isrc/libwbfs -Isrc/lzma -Isrc -I$(UI) -I. -Iwork
-CFLAGS += -O3 -Isrc/libwbfs -Isrc -I$(UI) -I. -Iwork
@@ -35,16 +48,22 @@ CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
ifeq ($(SYSTEM),cygwin)
CFLAGS += -Wno-format-truncation
else ifeq ($(SYSTEM),mac)
-@@ -317,7 +315,7 @@
+@@ -311,13 +305,10 @@
+
+ DEPFLAGS += -MMD
+
+-LDFLAGS += -static-libgcc
+-LDFLAGS := $(strip $(LDFLAGS))
+-
ifeq ($(HAVE_ZLIB),1)
LIBS += -lz
endif
-LIBS += -lm -lncurses $(XLIBS)
-+LIBS += -lm $(shell pkg-config --libs ncurses) -lbz2 $(XLIBS)
++LIBS += -lm $(shell $(PKG_CONFIG) --libs ncurses) -lbz2 $(XLIBS)
DISTRIB_RM = ./wit-v$(VERSION)-r
DISTRIB_BASE = wit-v$(VERSION)-r$(REVISION_NEXT)
-@@ -370,83 +368,70 @@
+@@ -370,83 +361,70 @@
# general rules
$(ALL_TOOLS_X): %: %.o $(ALL_OBJECTS) $(TOBJ_ALL) Makefile | $(HELPER_TOOLS)
@@ -144,7 +163,7 @@ CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
#
###############################################################################
-@@ -644,9 +629,8 @@
+@@ -644,9 +622,8 @@
.PHONY : gen-doc
gen-doc:
@@ -156,7 +175,16 @@ CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
#
#--------------------------
-@@ -764,8 +748,7 @@
+@@ -750,7 +727,7 @@
+
+ .PHONY : predef
+ predef:
+- @gcc -E -dM none.c | sort
++ @$(CC) -E -dM none.c | sort
+
+ #
+ #--------------------------
+@@ -764,8 +741,7 @@
#--------------------------
templates.sed: Makefile
@@ -166,7 +194,7 @@ CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
'/^~/ d;\n' \
's|@.@@@|$(VERSION_NUM)|g;\n' \
's|@@@@-@@-@@|$(DATE)|g;\n' \
-@@ -828,13 +811,12 @@
+@@ -828,13 +804,12 @@
.PHONY : test
test:
@@ -185,3 +213,66 @@ CFLAGS, use pkgconfig to determine ncurses libs, and use verbose build output.
#
#--------------------------
+--- a/makefiles-local/Makefile.local.i386
++++ b/makefiles-local/Makefile.local.i386
+@@ -5,6 +5,3 @@
+ # => copy Makefile.local to main directory and remove appropriate comments
+
+ #------------------------------------------------------------------------------
+-
+-#CFLAGS += -mtune=generic
+-CFLAGS += -march=i686
+--- a/makefiles-local/Makefile.local.x86_64
++++ b/makefiles-local/Makefile.local.x86_64
+@@ -5,6 +5,3 @@
+ # => copy Makefile.local to main directory and remove appropriate comments
+
+ #------------------------------------------------------------------------------
+-
+-CFLAGS += -march=x86-64
+-
+--- a/setup.sh
++++ b/setup.sh
+@@ -118,6 +118,6 @@
+
+ ---EOT---
+
+-gcc $xflags system.c -o system.tmp && ./system.tmp >>Makefile.setup
++${CC} $xflags system.c -o system.tmp && ./system.tmp >>Makefile.setup
+ rm -f system.tmp
+
+--- a/test-libwbfs/Makefile
++++ b/test-libwbfs/Makefile
+@@ -7,11 +7,6 @@
+
+ SHELL = /bin/bash
+
+-PRE ?=
+-CC = $(PRE)gcc
+-CPP = $(PRE)g++
+-STRIP = $(PRE)strip
+-
+ #-------------------------------------------------------------------------------
+ # files
+
+@@ -46,18 +41,14 @@
+ DEFINES = -DLARGE_FILES -D_FILE_OFFSET_BITS=64 $(XDEF)
+ DEFINES := $(strip $(DEFINES))
+
+-CFLAGS = -fomit-frame-pointer -fno-strict-aliasing
++CFLAGS += -fno-strict-aliasing
+ CFLAGS += -Wall -Wno-parentheses -Wno-unused-function
+-CFLAGS += -O3 -I../src/libwbfs -I.
++CFLAGS += -I../src/libwbfs -I.
+ CFLAGS += $(XFLAGS)
+ CFLAGS := $(strip $(CFLAGS))
+
+ DEPFLAGS += -MMD
+
+-LDFLAGS += -static-libgcc
+-#LDFLAGS += -static
+-LDFLAGS := $(strip $(LDFLAGS))
+-
+ LIBS += $(XLIBS)
+
+ #