summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/wxchtdecoder/files/wxchtdecoder-1.5a-wxgtk.patch37
-rw-r--r--games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild32
2 files changed, 69 insertions, 0 deletions
diff --git a/games-util/wxchtdecoder/files/wxchtdecoder-1.5a-wxgtk.patch b/games-util/wxchtdecoder/files/wxchtdecoder-1.5a-wxgtk.patch
new file mode 100644
index 000000000000..1eb61febe1bb
--- /dev/null
+++ b/games-util/wxchtdecoder/files/wxchtdecoder-1.5a-wxgtk.patch
@@ -0,0 +1,37 @@
+--- wxchtdecoder-1.5a.orig/source/chtdecoder.cc
++++ wxchtdecoder-1.5a/source/chtdecoder.cc
+@@ -64,26 +64,26 @@
+ const wxSize *CHTDecoder::APP_SIZE = new wxSize(640, 480);
+
+ namespace {
+- const wxCmdLineEntryDesc CMDLINE_DESC[] = {
++ wxCmdLineEntryDesc CMDLINE_DESC[] = {
+ {
+- wxCMD_LINE_SWITCH, wxT("h"), wxT("help"),
+- wxT("display usage information"), wxCMD_LINE_VAL_STRING,
++ wxCMD_LINE_SWITCH, "h", "help",
++ "display usage information", wxCMD_LINE_VAL_STRING,
+ wxCMD_LINE_OPTION_HELP
+ },
+
+ {
+- wxCMD_LINE_SWITCH, wxT("v"), wxT("version"),
+- wxT("display version information"), wxCMD_LINE_VAL_STRING,
++ wxCMD_LINE_SWITCH, "v", "version",
++ "display version information", wxCMD_LINE_VAL_STRING,
+ wxCMD_LINE_OPTION_HELP
+ },
+
+ {
+- wxCMD_LINE_SWITCH, wxT("f"), wxT("force-open"),
+- wxT("force opening of possibly invalid .CHT files")
++ wxCMD_LINE_SWITCH, "f", "force-open",
++ "force opening of possibly invalid .CHT files"
+ },
+
+ {
+- wxCMD_LINE_PARAM, 0, 0, wxT(".CHT file(s)"),
++ wxCMD_LINE_PARAM, 0, 0, ".CHT file(s)",
+ wxCMD_LINE_VAL_STRING, wxCMD_LINE_PARAM_MULTIPLE
+ },
+
diff --git a/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
new file mode 100644
index 000000000000..71c838660d4b
--- /dev/null
+++ b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit eutils wxwidgets
+
+DESCRIPTION="A program to decode .CHT files in Snes9x and ZSNES to plain text"
+HOMEPAGE="http://games.technoplaza.net/chtdecoder/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wxgtk.patch
+}
+
+src_configure() {
+ econf --with-wx-config=${WX_CONFIG}
+}
+
+src_install() {
+ dobin source/wxchtdecoder
+ dodoc docs/wxchtdecoder.txt
+}