summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/pyfa/Manifest3
-rw-r--r--games-util/pyfa/files/pyfa-1.15.1-import-pyfa.patch27
-rw-r--r--games-util/pyfa/files/pyfa-1.15.1-staticdata.patch61
-rw-r--r--games-util/pyfa/files/pyfa-1.20.2-html-export-path.patch33
-rw-r--r--games-util/pyfa/files/pyfa-1.21.4-html-export-path.patch33
-rw-r--r--games-util/pyfa/files/pyfa-1.33.1-import-pyfa.patch28
-rw-r--r--games-util/pyfa/files/pyfa-1.33.1-staticdata.patch59
-rw-r--r--games-util/pyfa/metadata.xml8
-rw-r--r--games-util/pyfa/pyfa-1.33.2.ebuild (renamed from games-util/pyfa/pyfa-1.21.3.ebuild)21
-rw-r--r--games-util/pyfa/pyfa-1.34.0.ebuild101
-rw-r--r--games-util/pyfa/pyfa-9999.ebuild21
11 files changed, 214 insertions, 181 deletions
diff --git a/games-util/pyfa/Manifest b/games-util/pyfa/Manifest
index d3cd0bd46079..89dbf388bec7 100644
--- a/games-util/pyfa/Manifest
+++ b/games-util/pyfa/Manifest
@@ -1 +1,2 @@
-DIST pyfa-1.21.3.tar.gz 7793523 BLAKE2B d0e4500d9760bfda34210e35ac3fae2ec76b3ecc6c43ecd5295edd473d41abd4074b5b3c1dc20cd8c74c491a2d55f86fea13e898720e18d1e2f6a1f96e800060 SHA512 b5a691873421ef2d3b01d8bfd7121c63f07b96c75837fd3b93a5b77b8163943336dcd5bb85f8dcc056ce61b5103d5331afd5a81c09eb06a7050112b5d1a26681
+DIST pyfa-1.33.2.tar.gz 8596509 BLAKE2B a00729be066a417cc4702f056506c2e248bc9a9076cab50706fc46669c9b9611f35b96b3096979edf620bc5b9f8341765b2768c032a9046a2629e0b121a2dca3 SHA512 333951ef53d8088c7264297402e072124a960feb1832eda2ea2dec5df2ddc438fd72ceb3f90c5fdad0fe3f9f2e32bb712db1d30bb3f8ded921d2b621b40270f2
+DIST pyfa-1.34.0.tar.gz 8629709 BLAKE2B 5b16296b675383a446bb21133c9e83726a92beb221babbf8fbe4b19f0f7e95bb19fd6050a5c2e3d5e602df4bbb83debfeefd6ec7efdbff35a47934ef9b29979f SHA512 4642efd4de5be4add3c3f994d7be9dbeeb231fe86229f7944d52f265527c7a79698d3da5ccac3018e02c6000b0da888ad0e64382e12f74b7dd7b3398e7bb2d48
diff --git a/games-util/pyfa/files/pyfa-1.15.1-import-pyfa.patch b/games-util/pyfa/files/pyfa-1.15.1-import-pyfa.patch
deleted file mode 100644
index f29b75d7fea0..000000000000
--- a/games-util/pyfa/files/pyfa-1.15.1-import-pyfa.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 6c7b6ab7d1aae47d3a3f72a7951c7de294be2917 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Tue, 6 Oct 2015 22:16:38 -0400
-Subject: [PATCH] Append $(python_get_sitedir)/pyfa to import path
-
-Ensures that pyfa's import statements continue to work for systemwide
-installation.
----
- pyfa.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/pyfa.py b/pyfa.py
-index 8189918..7b81f10 100755
---- a/pyfa.py
-+++ b/pyfa.py
-@@ -20,6 +20,8 @@
-
- import sys
- import re
-+import os
-+sys.path.append(os.path.join("%%SITEDIR%%", "pyfa"))
- import config
-
-
---
-2.6.0
-
diff --git a/games-util/pyfa/files/pyfa-1.15.1-staticdata.patch b/games-util/pyfa/files/pyfa-1.15.1-staticdata.patch
deleted file mode 100644
index 8b8fa913070a..000000000000
--- a/games-util/pyfa/files/pyfa-1.15.1-staticdata.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From c7bb5210ce9feebb753734b5c581acca9f5c9d06 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Tue, 6 Oct 2015 21:37:44 -0400
-Subject: [PATCH] make gameDB and imgs.zip paths settable from configforced
-
----
- config.py | 10 +++++++++-
- gui/bitmapLoader.py | 2 +-
- 2 files changed, 10 insertions(+), 2 deletions(-)
-
-diff --git a/config.py b/config.py
-index 4072236..a9e71ee 100644
---- a/config.py
-+++ b/config.py
-@@ -28,6 +28,7 @@ pyfaPath = None
- savePath = None
- saveDB = None
- gameDB = None
-+imgsZIP = None
-
-
- class StreamToLogger(object):
-@@ -66,6 +67,7 @@ def defPaths():
- global savePath
- global saveDB
- global gameDB
-+ global imgsZIP
- global saveInRoot
-
- if debug:
-@@ -117,7 +119,13 @@ def defPaths():
- # The database where the static EVE data from the datadump is kept.
- # This is not the standard sqlite datadump but a modified version created by eos
- # maintenance script
-- gameDB = os.path.join(pyfaPath, "eve.db")
-+ gameDB = getattr(configforced, "gameDB", None)
-+ if gameDB is None:
-+ gameDB = os.path.join(pyfaPath, "eve.db")
-+
-+ imgsZIP = getattr(configforced, "imgsZIP", None)
-+ if imgsZIP is None:
-+ imgsZIP = os.path.join(pyfaPath, "imgs.zip")
-
- ## DON'T MODIFY ANYTHING BELOW ##
- import eos.config
-diff --git a/gui/bitmapLoader.py b/gui/bitmapLoader.py
-index 45026be..02985c1 100644
---- a/gui/bitmapLoader.py
-+++ b/gui/bitmapLoader.py
-@@ -31,7 +31,7 @@ except ImportError:
- class BitmapLoader():
-
- try:
-- archive = zipfile.ZipFile(os.path.join(config.pyfaPath, 'imgs.zip'), 'r')
-+ archive = zipfile.ZipFile(config.imgsZIP, 'r')
- except IOError:
- archive = None
-
---
-2.6.0
-
diff --git a/games-util/pyfa/files/pyfa-1.20.2-html-export-path.patch b/games-util/pyfa/files/pyfa-1.20.2-html-export-path.patch
deleted file mode 100644
index b06906a83b58..000000000000
--- a/games-util/pyfa/files/pyfa-1.20.2-html-export-path.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From dc07b64245459ff75c638dedc14ac86bdf9bc176 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Mon, 16 Jul 2012 05:43:38 -0400
-Subject: [PATCH] Export fits to home directory, not python sitedir
-
----
- service/settings.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/service/settings.py b/service/settings.py
-index 60627e6..7087e5c 100644
---- a/service/settings.py
-+++ b/service/settings.py
-@@ -21,6 +21,7 @@ import cPickle
- import os.path
- import config
- import urllib2
-+import sys
-
- class SettingsProvider():
- BASE_PATH = os.path.join(config.savePath, "settings")
-@@ -221,7 +222,7 @@ class HTMLExportSettings():
- return cls._instance
-
- def __init__(self):
-- serviceHTMLExportDefaultSettings = {"enabled": False, "path": config.pyfaPath + os.sep + 'pyfaFits.html', "website": "null-sec.com" }
-+ serviceHTMLExportDefaultSettings = {"enabled": False, "path": unicode(os.path.expanduser(os.path.join('~', 'pyfaFits.html')), sys.getfilesystemencoding()), "website": "null-sec.com" }
- self.serviceHTMLExportSettings = SettingsProvider.getInstance().getSettings("pyfaServiceHTMLExportSettings", serviceHTMLExportDefaultSettings)
-
- def getEnabled(self):
---
-2.8.1
-
diff --git a/games-util/pyfa/files/pyfa-1.21.4-html-export-path.patch b/games-util/pyfa/files/pyfa-1.21.4-html-export-path.patch
deleted file mode 100644
index f35dfcbd2d98..000000000000
--- a/games-util/pyfa/files/pyfa-1.21.4-html-export-path.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From a596f7f5398f613a607ecc91e06ea651806b8b63 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Mon, 16 Jul 2012 05:43:38 -0400
-Subject: [PATCH] Export fits to home directory, not python sitedir
-
----
- service/settings.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/service/settings.py b/service/settings.py
-index cd1b33b..a883ca1 100644
---- a/service/settings.py
-+++ b/service/settings.py
-@@ -21,6 +21,7 @@ import cPickle
- import os.path
- import config
- import urllib2
-+import sys
-
- class SettingsProvider():
- BASE_PATH = os.path.join(config.savePath, "settings")
-@@ -221,7 +222,7 @@ class HTMLExportSettings():
- return cls._instance
-
- def __init__(self):
-- serviceHTMLExportDefaultSettings = {"enabled": False, "path": config.pyfaPath + os.sep + 'pyfaFits.html', "website": "null-sec.com", "minimal": False }
-+ serviceHTMLExportDefaultSettings = {"enabled": False, "path": unicode(os.path.expanduser(os.path.join('~', 'pyfaFits.html')), sys.getfilesystemencoding()), "website": "null-sec.com", "minimal": False }
- self.serviceHTMLExportSettings = SettingsProvider.getInstance().getSettings("pyfaServiceHTMLExportSettings", serviceHTMLExportDefaultSettings)
-
- def getEnabled(self):
---
-2.8.3
-
diff --git a/games-util/pyfa/files/pyfa-1.33.1-import-pyfa.patch b/games-util/pyfa/files/pyfa-1.33.1-import-pyfa.patch
new file mode 100644
index 000000000000..0c71ce69f720
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.33.1-import-pyfa.patch
@@ -0,0 +1,28 @@
+From c35467378232b1b21cca304f5dba37c687e51bca Mon Sep 17 00:00:00 2001
+From: Andreas Zuber <zuber@puzzle.ch>
+Date: Mon, 30 Oct 2017 09:52:32 +0100
+Subject: [PATCH 2/3] import pyfa
+
+Append $(python_get_sitedir)/pyfa to import path
+
+Ensures that pyfa's import statements continue to work for systemwide
+installation.
+---
+ pyfa.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pyfa.py b/pyfa.py
+index 4faa1edd..9cfa5e23 100755
+--- a/pyfa.py
++++ b/pyfa.py
+@@ -23,6 +23,7 @@ import os
+ import platform
+ import re
+ import sys
++sys.path.append(os.path.join("%%SITEDIR%%", "pyfa"))
+ import traceback
+ from optparse import AmbiguousOptionError, BadOptionError, OptionParser
+
+--
+2.14.3
+
diff --git a/games-util/pyfa/files/pyfa-1.33.1-staticdata.patch b/games-util/pyfa/files/pyfa-1.33.1-staticdata.patch
new file mode 100644
index 000000000000..76a705e2c832
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.33.1-staticdata.patch
@@ -0,0 +1,59 @@
+From 54f0cd42c6f022e010c63ba7b1f123f78001b490 Mon Sep 17 00:00:00 2001
+From: Andreas Zuber <zuber@puzzle.ch>
+Date: Mon, 30 Oct 2017 09:53:31 +0100
+Subject: [PATCH 3/3] staticdata
+
+make gameDB and imgs.zip paths settable from configforced
+---
+ config.py | 7 +++++++
+ gui/bitmapLoader.py | 2 +-
+ 2 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/config.py b/config.py
+index b15c30a3..a5a07acb 100644
+--- a/config.py
++++ b/config.py
+@@ -30,6 +30,7 @@ savePath = None
+ saveDB = None
+ gameDB = None
+ logPath = None
++imgsZIP = None
+
+
+ def isFrozen():
+@@ -61,6 +62,7 @@ def defPaths(customSavePath):
+ global savePath
+ global saveDB
+ global gameDB
++ global imgsZIP
+ global saveInRoot
+
+ pyfalog.debug("Configuring Pyfa")
+@@ -100,6 +102,11 @@ def defPaths(customSavePath):
+ if not gameDB:
+ gameDB = os.path.join(pyfaPath, "eve.db")
+
++ imgsZIP = getattr(configforced, "imgsZIP", imgsZIP)
++ if not imgsZIP:
++ imgsZIP = os.path.join(pyfaPath, "imgs.zip")
++
++
+ # DON'T MODIFY ANYTHING BELOW
+ import eos.config
+
+diff --git a/gui/bitmapLoader.py b/gui/bitmapLoader.py
+index eb53b1f1..86036001 100644
+--- a/gui/bitmapLoader.py
++++ b/gui/bitmapLoader.py
+@@ -37,7 +37,7 @@ except ImportError:
+
+ class BitmapLoader(object):
+ try:
+- archive = zipfile.ZipFile(os.path.join(config.pyfaPath, 'imgs.zip'), 'r')
++ archive = zipfile.ZipFile(config.imgsZIP, 'r')
+ logging.info("Using zipped image files.")
+ except IOError:
+ logging.info("Using local image files.")
+--
+2.14.3
+
diff --git a/games-util/pyfa/metadata.xml b/games-util/pyfa/metadata.xml
index 2c0b85a4e6ef..c556f4ff0717 100644
--- a/games-util/pyfa/metadata.xml
+++ b/games-util/pyfa/metadata.xml
@@ -2,8 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>tetromino@gentoo.org</email>
- <name>Alexandre Rostovtsev</name>
+ <email>a.zuber@gmx.ch</email>
+ <name>Andreas Zuber</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
Pyfa is the Python Fitting Assistant, a standalone application for creating
diff --git a/games-util/pyfa/pyfa-1.21.3.ebuild b/games-util/pyfa/pyfa-1.33.2.ebuild
index ea133f7beb13..dbd5180ef370 100644
--- a/games-util/pyfa/pyfa-1.21.3.ebuild
+++ b/games-util/pyfa/pyfa-1.33.2.ebuild
@@ -18,14 +18,16 @@ if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="~amd64 ~x86"
fi
IUSE="+graph"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.5[${PYTHON_USEDEP}]
dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ >=dev-python/logbook-1.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
graph? (
dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}] )
@@ -36,16 +38,13 @@ DEPEND="app-arch/zip"
src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work
- edos2unix config.py pyfa.py service/settings.py
+ edos2unix config.py pyfa.py gui/bitmapLoader.py service/settings.py
# load gameDB and images from separate staticdata directory
- eapply "${FILESDIR}/${PN}-1.15.1-staticdata.patch"
-
- # do not try to save exported html to python sitedir
- eapply "${FILESDIR}/${PN}-1.20.2-html-export-path.patch"
+ eapply "${FILESDIR}/${PN}-1.33.1-staticdata.patch"
# fix import path in the main script for systemwide installation
- eapply "${FILESDIR}/${PN}-1.15.1-import-pyfa.patch"
+ eapply "${FILESDIR}/${PN}-1.33.1-import-pyfa.patch"
eapply_user
@@ -84,10 +83,8 @@ src_install() {
popd > /dev/null || die
dodoc README.md
- insinto /usr/share/icons/hicolor/32x32/apps
- doins imgs/gui/pyfa.png
- insinto /usr/share/icons/hicolor/64x64/apps
- newins imgs/gui/pyfa64.png pyfa.png
+ doicon -s 32 imgs/gui/pyfa.png
+ newicon -s 64 imgs/gui/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}
diff --git a/games-util/pyfa/pyfa-1.34.0.ebuild b/games-util/pyfa/pyfa-1.34.0.ebuild
new file mode 100644
index 000000000000..dbd5180ef370
--- /dev/null
+++ b/games-util/pyfa/pyfa-1.34.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit eutils gnome2-utils python-r1
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="https://github.com/pyfa-org/Pyfa"
+
+LICENSE="GPL-3+ LGPL-2.1+ CC-BY-2.5 free-noncomm"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="+graph"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.5[${PYTHON_USEDEP}]
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ >=dev-python/logbook-1.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ graph? (
+ dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+DEPEND="app-arch/zip"
+
+[[ ${PV} = 9999 ]] || S=${WORKDIR}/Pyfa-${PV}
+
+src_prepare() {
+ # get rid of CRLF line endings introduced in 1.1.10 so patches work
+ edos2unix config.py pyfa.py gui/bitmapLoader.py service/settings.py
+
+ # load gameDB and images from separate staticdata directory
+ eapply "${FILESDIR}/${PN}-1.33.1-staticdata.patch"
+
+ # fix import path in the main script for systemwide installation
+ eapply "${FILESDIR}/${PN}-1.33.1-import-pyfa.patch"
+
+ eapply_user
+
+ touch __init__.py
+
+ pyfa_make_configforced() {
+ mkdir -p "${BUILD_DIR}" || die
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ -e "s:%%EPREFIX%%:${EPREFIX}:" \
+ "${FILESDIR}/configforced-1.15.1.py" > "${BUILD_DIR}/configforced.py"
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ pyfa.py > "${BUILD_DIR}/pyfa"
+ }
+ python_foreach_impl pyfa_make_configforced
+}
+
+src_install() {
+ pyfa_py_install() {
+ local packagedir=$(python_get_sitedir)/${PN}
+ insinto "${packagedir}"
+ doins -r eos gui service utils config*.py __init__.py
+ [[ -e info.py ]] && doins info.py # only in zip releases
+ doins "${BUILD_DIR}/configforced.py"
+ python_doscript "${BUILD_DIR}/pyfa"
+ python_optimize
+ }
+ python_foreach_impl pyfa_py_install
+
+ insinto /usr/share/${PN}
+ doins eve.db
+
+ einfo "Compressing images ..."
+ pushd imgs > /dev/null || die
+ zip -r imgs.zip * || die "zip failed"
+ doins imgs.zip
+ popd > /dev/null || die
+
+ dodoc README.md
+ doicon -s 32 imgs/gui/pyfa.png
+ newicon -s 64 imgs/gui/pyfa64.png pyfa.png
+ domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-util/pyfa/pyfa-9999.ebuild b/games-util/pyfa/pyfa-9999.ebuild
index 2fa0e26c3620..dbd5180ef370 100644
--- a/games-util/pyfa/pyfa-9999.ebuild
+++ b/games-util/pyfa/pyfa-9999.ebuild
@@ -18,14 +18,16 @@ if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="~amd64 ~x86"
fi
IUSE="+graph"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.5[${PYTHON_USEDEP}]
dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ >=dev-python/logbook-1.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
graph? (
dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}] )
@@ -36,16 +38,13 @@ DEPEND="app-arch/zip"
src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work
- edos2unix config.py pyfa.py service/settings.py
+ edos2unix config.py pyfa.py gui/bitmapLoader.py service/settings.py
# load gameDB and images from separate staticdata directory
- eapply "${FILESDIR}/${PN}-1.15.1-staticdata.patch"
-
- # do not try to save exported html to python sitedir
- eapply "${FILESDIR}/${PN}-1.21.4-html-export-path.patch"
+ eapply "${FILESDIR}/${PN}-1.33.1-staticdata.patch"
# fix import path in the main script for systemwide installation
- eapply "${FILESDIR}/${PN}-1.15.1-import-pyfa.patch"
+ eapply "${FILESDIR}/${PN}-1.33.1-import-pyfa.patch"
eapply_user
@@ -84,10 +83,8 @@ src_install() {
popd > /dev/null || die
dodoc README.md
- insinto /usr/share/icons/hicolor/32x32/apps
- doins imgs/gui/pyfa.png
- insinto /usr/share/icons/hicolor/64x64/apps
- newins imgs/gui/pyfa64.png pyfa.png
+ doicon -s 32 imgs/gui/pyfa.png
+ newicon -s 64 imgs/gui/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}