summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomekbd')
-rw-r--r--gnome-base/libgnomekbd/Manifest1
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-3.6.0.ebuild37
-rw-r--r--gnome-base/libgnomekbd/metadata.xml5
3 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/Manifest b/gnome-base/libgnomekbd/Manifest
new file mode 100644
index 000000000000..7a42ab8505fe
--- /dev/null
+++ b/gnome-base/libgnomekbd/Manifest
@@ -0,0 +1 @@
+DIST libgnomekbd-3.6.0.tar.xz 373588 SHA256 c41ea5b0f64da470925ba09f9f1b46b26b82d4e433e594b2c71eab3da8856a09 SHA512 27d0711eeebba91ca0dbed079c17acfec97116153a01f4f6e78cb30044afc534c438f655c6836b74b377acb8116d3b70e1f09578f182bb4fc51d8d05e89c6f17 WHIRLPOOL d64b284471e1ba62f13c06c12a89ccc86548fe77f1ab85dfce6d97d5a4bacccb510f0f0181229a8c8f55e2142362148b7614036520305a1fcad444beaf8863df
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.6.0.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.6.0.ebuild
new file mode 100644
index 000000000000..2f96eb77de0f
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-3.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=x11-libs/libxklavier-5.2[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable introspection)
+ $(use_enable test tests)"
+ gnome2_src_configure
+}
diff --git a/gnome-base/libgnomekbd/metadata.xml b/gnome-base/libgnomekbd/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-base/libgnomekbd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>