summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomekbd')
-rw-r--r--gnome-base/libgnomekbd/Manifest1
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/Manifest b/gnome-base/libgnomekbd/Manifest
index 7a42ab8505fe..89d9049303ec 100644
--- a/gnome-base/libgnomekbd/Manifest
+++ b/gnome-base/libgnomekbd/Manifest
@@ -1 +1,2 @@
+DIST libgnomekbd-3.22.0.1.tar.xz 450572 SHA256 4efdb6b8ec92f04caced710b5edb285fb27715059ed6ca5e100b6933999a93de SHA512 a4d2e6feac18cb7e3a65553dcd587f284c71154d3058866b0b6285b1acca549d33d0bd0014a97f1e153eb5e2a5a16e8b18eb680ce0078edd80bdd68a51ac080e WHIRLPOOL 411e5c8180f7c87bc19df050ea817db2998ea35a15baa04f7ebfee28887401bbe0c87dc9f91f123a9b90cd0bd070d69e8a32beea188b53d42d108410deacb04d
DIST libgnomekbd-3.6.0.tar.xz 373588 SHA256 c41ea5b0f64da470925ba09f9f1b46b26b82d4e433e594b2c71eab3da8856a09 SHA512 27d0711eeebba91ca0dbed079c17acfec97116153a01f4f6e78cb30044afc534c438f655c6836b74b377acb8116d3b70e1f09578f182bb4fc51d8d05e89c6f17 WHIRLPOOL d64b284471e1ba62f13c06c12a89ccc86548fe77f1ab85dfce6d97d5a4bacccb510f0f0181229a8c8f55e2142362148b7614036520305a1fcad444beaf8863df
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild
new file mode 100644
index 000000000000..6b7935a2188c
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-3.22.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="https://www.gnome.org"
+
+LICENSE="LGPL-2+"
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=x11-libs/libxklavier-5.2[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}