summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomekbd')
-rw-r--r--gnome-base/libgnomekbd/files/3.26.0-glib-2.60-compat.patch35
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild6
2 files changed, 40 insertions, 1 deletions
diff --git a/gnome-base/libgnomekbd/files/3.26.0-glib-2.60-compat.patch b/gnome-base/libgnomekbd/files/3.26.0-glib-2.60-compat.patch
new file mode 100644
index 000000000000..c6bcf66160f9
--- /dev/null
+++ b/gnome-base/libgnomekbd/files/3.26.0-glib-2.60-compat.patch
@@ -0,0 +1,35 @@
+From 7e0b6f0a96477c5d12434231ea413d3a16658ed0 Mon Sep 17 00:00:00 2001
+From: Abderrahim Kitouni <akitouni@gnome.org>
+Date: Tue, 18 Dec 2018 10:54:06 +0100
+Subject: [PATCH] rename g_strv_equal to gkbd_strv_equal
+
+it conflicts with the newly added g_strv_equal in glib
+---
+ libgnomekbd/gkbd-keyboard-config.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libgnomekbd/gkbd-keyboard-config.c b/libgnomekbd/gkbd-keyboard-config.c
+index bbe6904..00dc429 100644
+--- a/libgnomekbd/gkbd-keyboard-config.c
++++ b/libgnomekbd/gkbd-keyboard-config.c
+@@ -52,7 +52,7 @@ const gchar *GKBD_KEYBOARD_CONFIG_ACTIVE[] = {
+ */
+
+ static gboolean
+-g_strv_equal (gchar ** l1, gchar ** l2)
++gkbd_strv_equal (gchar ** l1, gchar ** l2)
+ {
+ if (l1 == l2)
+ return TRUE;
+@@ -555,7 +555,7 @@ gkbd_keyboard_config_equals (GkbdKeyboardConfig * kbd_config1,
+ (kbd_config2->model != NULL) &&
+ g_ascii_strcasecmp (kbd_config1->model, kbd_config2->model))
+ return False;
+- if (!g_strv_equal (kbd_config1->layouts_variants,
++ if (!gkbd_strv_equal (kbd_config1->layouts_variants,
+ kbd_config2->layouts_variants))
+ return False;
+
+--
+2.17.0
+
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild
index 9bc10e4ce687..d07c943fef68 100644
--- a/gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild
+++ b/gnome-base/libgnomekbd/libgnomekbd-3.26.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,6 +26,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PV}-glib-2.60-compat.patch
+)
+
src_configure() {
gnome2_src_configure \
--disable-static \