summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.ebuild
new file mode 100644
index 000000000000..7156fa24cd70
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+COMMIT="71afc1a01df765bf03cc756d309be1e040184f20"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+S="${WORKDIR}/Control_Blur_Effect_On_Lock_Screen-${COMMIT}/${extension_uuid}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf LICENSE README.md schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}