summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-user-docs')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-3.20.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index 074955ee5aaf..283474e4509c 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1 +1,2 @@
DIST gnome-user-docs-3.18.1.tar.xz 14213948 SHA256 83e52528de6afe4412679d7fd8c7f8124b07770b4e291592f24e9e50657efae4 SHA512 161fd15f852d5cc2dbffec304d6ab09ae92cd7ff0d457194acd40e530ca34a3b49fa23a6b51542676b53045ea2c7726b2f328a11e295dbc0d13da60b1ff622e0 WHIRLPOOL 855ef6926c1ac89b59910d66a38afa48a6dcc34486bec1c441990e94e379a5d91b806c27ba58b5b116f840149c44fd8ab5743c20716f72422e2c2814d97cebcc
+DIST gnome-user-docs-3.20.2.tar.xz 14103132 SHA256 3e998ba05956582219b068e7f7abd9baebf8bc4067c9618d6d0be92c68a5bf32 SHA512 a10b4869922c3f459fb7b6580a845e108881a3083232097ce943ee5afea089667ddd77bf884a62355ab302a32c56fb5b437af1dff3705e44d04375405a79a1d5 WHIRLPOOL 7062dee27898b62d7b2eb61dbaa7698c9171e7c339f5a5a9cdb133d528f12f421e831fa6492548eaee9e984ac50d16552234f9de526f964e90dee077f7c9496a
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-3.20.2.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-3.20.2.ebuild
new file mode 100644
index 000000000000..faa69e2f548f
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-3.20.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ test? ( dev-libs/libxml2 )
+"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}