summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/sushi/sushi-3.38.0.ebuild')
-rw-r--r--gnome-extra/sushi/sushi-3.38.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/sushi/sushi-3.38.0.ebuild b/gnome-extra/sushi/sushi-3.38.0.ebuild
new file mode 100644
index 000000000000..9a2dfada0ca0
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.38.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+IUSE="office wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+# Optional app-office/libreoffice support (OOo to pdf and then preview)
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ media-libs/musicbrainz:5=
+ net-libs/webkit-gtk:4[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ office? ( app-office/libreoffice )
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_feature wayland) \
+ $(meson_feature X X11)
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}